summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-09-29 02:01:42 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-09-29 02:01:42 +0000
commit36254ae2b66d547a6e747df72eb95f1e4701e24b (patch)
tree1bd3880ede8c38ec77c595c22f5b2b0ce64f8c20 /games-fps/tribes2
parentKeyworded ~sparc wrt #64135 (Manifest recommit) (diff)
downloadgentoo-2-36254ae2b66d547a6e747df72eb95f1e4701e24b.tar.gz
gentoo-2-36254ae2b66d547a6e747df72eb95f1e4701e24b.tar.bz2
gentoo-2-36254ae2b66d547a6e747df72eb95f1e4701e24b.zip
Added DEPEND on loki_patch and closing bug #53924.
Diffstat (limited to 'games-fps/tribes2')
-rw-r--r--games-fps/tribes2/ChangeLog5
-rw-r--r--games-fps/tribes2/tribes2-25034.ebuild39
2 files changed, 27 insertions, 17 deletions
diff --git a/games-fps/tribes2/ChangeLog b/games-fps/tribes2/ChangeLog
index c280c8a4a655..cb75587705d1 100644
--- a/games-fps/tribes2/ChangeLog
+++ b/games-fps/tribes2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/tribes2
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/ChangeLog,v 1.5 2004/07/01 11:18:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/ChangeLog,v 1.6 2004/09/29 02:01:42 wolf31o2 Exp $
+
+ 28 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> tribes2-25034.ebuild:
+ Added DEPEND on loki_patch and closing bug #53924.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> tribes2-25034.ebuild:
virtual/glibc -> virtual/libc
diff --git a/games-fps/tribes2/tribes2-25034.ebuild b/games-fps/tribes2/tribes2-25034.ebuild
index 667cf0b8bce9..b1a3e3ba3e46 100644
--- a/games-fps/tribes2/tribes2-25034.ebuild
+++ b/games-fps/tribes2/tribes2-25034.ebuild
@@ -1,25 +1,27 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/tribes2-25034.ebuild,v 1.5 2004/07/01 11:18:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tribes2/tribes2-25034.ebuild,v 1.6 2004/09/29 02:01:42 wolf31o2 Exp $
inherit games
IUSE=""
DESCRIPTION="Tribes 2 - Team Combat on an Epic Scale"
HOMEPAGE="http://www.lokigames.com/products/tribes2/"
-SRC_URI="http://www.libsdl.org/projects/tribes2/release/tribes2-${PV}-cdrom-x86.run
- http://dl1.ilangame.com/Tribes%20Series/Tribes%202/Patches/tribes2-${PV}-cdrom-x86.run
- http://3dgamers.planetmirror.com/pub/3dgamers/games/tribes2/tribes2-${PV}-cdrom-x86.run"
+SRC_URI="http://www.libsdl.org/projects/${PN}/release/${P}-cdrom-x86.run
+ mirror://3dgamers/pub/3dgamers/games/${PN}/${P}-cdrom-x86.run"
LICENSE="LOKI-EULA"
SLOT="0"
KEYWORDS="x86"
RESTRICT="nostrip nomirror"
-DEPEND="virtual/libc"
+DEPEND="virtual/libc
+ games-util/loki_patch"
RDEPEND="${DEPEND}
virtual/opengl"
+S=${WORKDIR}
+
dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
@@ -37,7 +39,7 @@ src_unpack() {
src_install() {
dodir ${dir}
einfo "Copying files... this may take a while..."
- exeinto /opt/${PN}
+ exeinto ${dir}
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic}
cp ${CDROM_ROOT}/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} ${Ddir}
@@ -46,28 +48,33 @@ src_install() {
tar xzf ${CDROM_ROOT}/profiles.tar.gz -C ${Ddir} || die "uncompressing profiles"
# Base (Music, Textures, Maps, etc.)
- cp -rf ${CDROM_ROOT}/base ${Ddir}
+ cp -rf ${CDROM_ROOT}/base ${CDROM_ROOT}/menu ${Ddir}
- cp -rf ${CDROM_ROOT}/menu ${Ddir}
+ cd ${S}
+ loki_patch --verify patch.dat
+ loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
find ${Ddir} -exec touch '{}' \;
- dodir ${GAMES_BINDIR}
- dosym ${dir}/t2launch ${GAMES_BINDIR}/t2launch
- dosym ${dir}/tribes2 ${GAMES_BINDIR}/tribes2
- dosym ${dir}/tribes2.dynamic ${GAMES_BINDIR}/tribes2.dynamic
- dosym ${dir}/tribes2d ${GAMES_BINDIR}/tribes2d
- dosym ${dir}/tribes2d-restart.sh ${GAMES_BINDIR}/tribes2d-restart.sh
- dosym ${dir}/tribes2d.dynamic ${GAMES_BINDIR}/tribes2d.dynamic
+ #dodir ${GAMES_BINDIR}
+ #dosym ${dir}/t2launch ${GAMES_BINDIR}/t2launch
+ #dosym ${dir}/tribes2 ${GAMES_BINDIR}/tribes2
+ #dosym ${dir}/tribes2.dynamic ${GAMES_BINDIR}/tribes2.dynamic
+ #dosym ${dir}/tribes2d ${GAMES_BINDIR}/tribes2d
+ #dosym ${dir}/tribes2d-restart.sh ${GAMES_BINDIR}/tribes2d-restart.sh
+ #dosym ${dir}/tribes2d.dynamic ${GAMES_BINDIR}/tribes2d.dynamic
+
+ games_make_wrapper t2launch ./t2launch ${dir}
+
insinto /usr/share/pixmaps
newins ${CDROM_ROOT}/icon.xpm Tribes2.xpm
doins ${CDROM_ROOT}/icon.bmp
prepgamesdirs
- make_desktop_entry ${PN} "Tribes 2" "Tribes2.xpm"
+ make_desktop_entry t2launch "Tribes 2" "Tribes2.xpm"
}
pkg_postinst() {