summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-11-18 13:23:02 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-11-18 13:23:02 +0000
commitdedaf54f3dda8d58df9191be561b3b7b355200bc (patch)
tree0af9562abd0cd3ec9b39c5c6f267daa07e028555 /games-fps/tremulous
parentVersion cleanup, and fix for bug #236586 (diff)
downloadgentoo-2-dedaf54f3dda8d58df9191be561b3b7b355200bc.tar.gz
gentoo-2-dedaf54f3dda8d58df9191be561b3b7b355200bc.tar.bz2
gentoo-2-dedaf54f3dda8d58df9191be561b3b7b355200bc.zip
rm
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.6 i686)
Diffstat (limited to 'games-fps/tremulous')
-rw-r--r--games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch20
-rw-r--r--games-fps/tremulous/tremulous-1.1.0.ebuild92
2 files changed, 0 insertions, 112 deletions
diff --git a/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch b/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch
deleted file mode 100644
index f04398fa9c5d..000000000000
--- a/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/tools/asm/cmdlib.c
-+++ src/tools/asm/cmdlib.c
-@@ -313,7 +313,7 @@
- char *ExpandPath (const char *path)
- {
- static char full[1024];
-- if (!qdir)
-+ if (!qdir[0])
- Error ("ExpandPath called without qdir set");
- if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
- strcpy( full, path );
-@@ -326,7 +326,7 @@
- char *ExpandGamePath (const char *path)
- {
- static char full[1024];
-- if (!qdir)
-+ if (!qdir[0])
- Error ("ExpandGamePath called without qdir set");
- if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
- strcpy( full, path );
diff --git a/games-fps/tremulous/tremulous-1.1.0.ebuild b/games-fps/tremulous/tremulous-1.1.0.ebuild
deleted file mode 100644
index e7697c93d75b..000000000000
--- a/games-fps/tremulous/tremulous-1.1.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0.ebuild,v 1.6 2008/02/29 19:22:46 carlo Exp $
-
-inherit eutils toolchain-funcs games
-
-DESCRIPTION="Team-based aliens vs humans FPS with buildable structures"
-HOMEPAGE="http://tremulous.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip
- http://0day.icculus.org/mirrors/${PN}/${P}.zip
- ftp://ftp.wireplay.co.uk/pub/quake3arena/mods/${PN}/${P}.zip"
-
-LICENSE="GPL-2
- CCPL-Attribution-ShareAlike-2.5"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="dedicated openal opengl vorbis"
-
-UIDEPEND="openal? ( media-libs/openal )
- media-libs/libsdl
- vorbis? ( media-libs/libogg media-libs/libvorbis )
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext"
-RDEPEND="opengl? ( ${UIDEPEND} )
- !opengl? ( !dedicated? ( ${UIDEPEND} ) )
- !games-fps/tremulous-bin"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${PN}/${P}-src
-
-pkg_setup() {
- games_pkg_setup
-
- if use amd64 ; then
- ewarn "emerge games-fps/tremulous-bin instead for better performance."
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${PN}
-
- unpack ./${P}-src.tar.gz
-}
-
-src_compile() {
- buildit() { use $1 && echo 1 || echo 0 ; }
-
- local build_client=1
- if use dedicated && ! use opengl ; then
- build_client=0
- fi
-
- emake \
- BUILD_CLIENT=${build_client} \
- BUILD_SERVER=$(buildit dedicated) \
- CC="$(tc-getCC)" \
- DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
- USE_CODEC_VORBIS=$(buildit vorbis) \
- USE_OPENAL=$(buildit openal) \
- USE_LOCAL_HEADERS=0 \
- OPTIMIZE= \
- || die "emake failed"
-}
-
-src_install() {
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../base || die "doins -r failed"
-
- dodoc ChangeLog ../manual.pdf
-
- local bindir=build/release-linux-${ARCH}
-
- if use opengl || ! use dedicated ; then
- newgamesbin ${bindir}/${PN}.${ARCH} ${PN} \
- || die "newgamesbin client failed"
- doicon misc/${PN}.xpm
- make_desktop_entry ${PN} Tremulous ${PN}
- fi
-
- if use dedicated ; then
- newgamesbin ${bindir}/tremded.${ARCH} ${PN}-ded \
- || die "newgamesbin ded failed"
- fi
-
- prepgamesdirs
-}