summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-31 00:30:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-31 00:30:47 +0000
commit71ada7c7ea2880ecfd26aea5f461686f8ac5681e (patch)
tree408925679a864ae2f6482bf2f73416bc7fd9e70d /games-fps/quake3
parentRemove compatibility symlink (we don't have software needing them in Portage)... (diff)
downloadgentoo-2-71ada7c7ea2880ecfd26aea5f461686f8ac5681e.tar.gz
gentoo-2-71ada7c7ea2880ecfd26aea5f461686f8ac5681e.tar.bz2
gentoo-2-71ada7c7ea2880ecfd26aea5f461686f8ac5681e.zip
add Redhat patch to fix bot loading on 64bit (bug #353257)
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/quake3-1.36-bots.patch20
-rw-r--r--games-fps/quake3/quake3-1.36.ebuild7
3 files changed, 31 insertions, 4 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index a67cecb56edc..5af7054c38c4 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake3
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.55 2010/11/28 05:29:05 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.56 2011/01/31 00:30:47 mr_bones_ Exp $
+
+ 31 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> quake3-1.36.ebuild,
+ +files/quake3-1.36-bots.patch:
+ add Redhat patch to fix bot loading on 64bit (bug #353257)
28 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org> quake3-1.36.ebuild,
quake3-9999.ebuild:
diff --git a/games-fps/quake3/files/quake3-1.36-bots.patch b/games-fps/quake3/files/quake3-1.36-bots.patch
new file mode 100644
index 000000000000..31d2f2041c6f
--- /dev/null
+++ b/games-fps/quake3/files/quake3-1.36-bots.patch
@@ -0,0 +1,20 @@
+--- code/botlib/l_script.c.orig 2009-11-02 20:29:23.000000000 +0100
++++ code/botlib/l_script.c 2009-11-02 22:21:40.000000000 +0100
+@@ -1118,7 +1118,7 @@
+ {
+ if (*string == '\"')
+ {
+- strcpy(string, string+1);
++ memmove(string, string+1, strlen(string));
+ } //end if
+ if (string[strlen(string)-1] == '\"')
+ {
+@@ -1135,7 +1135,7 @@
+ {
+ if (*string == '\'')
+ {
+- strcpy(string, string+1);
++ memmove(string, string+1, strlen(string));
+ } //end if
+ if (string[strlen(string)-1] == '\'')
+ {
diff --git a/games-fps/quake3/quake3-1.36.ebuild b/games-fps/quake3/quake3-1.36.ebuild
index a6d572b001a8..5f6be5b7f168 100644
--- a/games-fps/quake3/quake3-1.36.ebuild
+++ b/games-fps/quake3/quake3-1.36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.36.ebuild,v 1.2 2010/11/28 05:29:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.36.ebuild,v 1.3 2011/01/31 00:30:47 mr_bones_ Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -49,6 +49,9 @@ src_unpack() {
src_prepare() {
sed -i -e '/INSTALL/s: -s : :' Makefile || die
+ if [[ ${PV} != 9999* ]] ; then
+ epatch "${FILESDIR}"/${P}-bots.patch
+ fi
}
src_compile() {