summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-02 21:46:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-02 21:46:18 +0000
commitaae1384b30e8b07124fd21822438cbd2aba4478d (patch)
treea9bca84b91fabba3c9103647752a613cc34fd0ff /games-fps/nprquake-sdl
parentremove versions affected by bug #182389 (diff)
downloadgentoo-2-aae1384b30e8b07124fd21822438cbd2aba4478d.tar.gz
gentoo-2-aae1384b30e8b07124fd21822438cbd2aba4478d.tar.bz2
gentoo-2-aae1384b30e8b07124fd21822438cbd2aba4478d.zip
remove need for an executable stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-fps/nprquake-sdl')
-rw-r--r--games-fps/nprquake-sdl/ChangeLog7
-rw-r--r--games-fps/nprquake-sdl/files/1-gentoo.patch59
-rw-r--r--games-fps/nprquake-sdl/files/nprquake-sdl-1-exec-stack.patch36
-rw-r--r--games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild10
4 files changed, 81 insertions, 31 deletions
diff --git a/games-fps/nprquake-sdl/ChangeLog b/games-fps/nprquake-sdl/ChangeLog
index 850dc8e695f0..74b30f457689 100644
--- a/games-fps/nprquake-sdl/ChangeLog
+++ b/games-fps/nprquake-sdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/nprquake-sdl
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/ChangeLog,v 1.6 2007/03/12 14:44:51 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/ChangeLog,v 1.7 2007/07/02 21:46:18 nyhm Exp $
+
+ 02 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/nprquake-sdl-1-exec-stack.patch, files/1-gentoo.patch,
+ nprquake-sdl-1-r1.ebuild:
+ remove need for an executable stack
12 Mar 2007; Marius Mauch <genone@gentoo.org> nprquake-sdl-1-r1.ebuild:
Replacing einfo with elog
diff --git a/games-fps/nprquake-sdl/files/1-gentoo.patch b/games-fps/nprquake-sdl/files/1-gentoo.patch
index 6d45b15c6b75..0f1ec8dcba2d 100644
--- a/games-fps/nprquake-sdl/files/1-gentoo.patch
+++ b/games-fps/nprquake-sdl/files/1-gentoo.patch
@@ -1,33 +1,20 @@
---- NPRQuake-SDL/Makefile
-+++ NPRQuake-SDL/Makefile
-@@ -1,4 +1,4 @@
+--- Makefile
++++ Makefile
+@@ -1,10 +1,10 @@
-RELEASE_CFLAGS=-Dstricmp=strcasecmp -mcpu=i586 -march=i586 -O6 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
+RELEASE_CFLAGS=-Dstricmp=strcasecmp $(OPTFLAGS) -DGENTOO_LIBDIR='\"$(GENTOO_LIBDIR)\"' -DGENTOO_DATADIR='\"$(GENTOO_DATADIR)\"'
DEBUG_CFLAGS=-Dstricmp=strcasecmp -g
---- NPRQuake-SDL/NPRQuakeSrc/Makefile
-+++ NPRQuake-SDL/NPRQuakeSrc/Makefile
-@@ -29,7 +29,7 @@
-
- CC=gcc
-
--RELEASE_CFLAGS=$(BASE_CFLAGS) -mcpu=i586 -march=i586 -O6 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
-+RELEASE_CFLAGS=$(BASE_CFLAGS) $(OPTFLAGS) -DGENTOO_LIBDIR='\"$(GENTOO_LIBDIR)\"' -DGENTOO_DATADIR='\"$(GENTOO_DATADIR)\"'
- DEBUG_CFLAGS=$(BASE_CFLAGS) -g
- LDFLAGS=-lm
CFLAGS=$(RELEASE_CFLAGS)
-@@ -176,7 +176,7 @@
- $(DO_GL_CC)
- $(BUILDDIR)/glquake/common.o : common.c
-- $(DO_GL_DEBUG_CC)
-+ $(DO_GL_CC)
+-DR_FLAGS=-DGLQUAKE -D_DLL_BUILD -shared
++DR_FLAGS=-DGLQUAKE -D_DLL_BUILD -shared -fPIC
- $(BUILDDIR)/glquake/console.o : console.c
- $(DO_GL_CC)
---- NPRQuake-SDL/NPRQuakeSrc/common.c
-+++ NPRQuake-SDL/NPRQuakeSrc/common.c
+ renderers=build/dr_default.so build/brush.so build/bprint.so build/sketch.so
+
+--- NPRQuakeSrc/common.c
++++ NPRQuakeSrc/common.c
@@ -1775,11 +1775,16 @@
// start up with GAMENAME by default (id1)
//
@@ -55,8 +42,8 @@
}
//
---- NPRQuake-SDL/NPRQuakeSrc/gl_rmisc.c
-+++ NPRQuake-SDL/NPRQuakeSrc/gl_rmisc.c
+--- NPRQuakeSrc/gl_rmisc.c
++++ NPRQuakeSrc/gl_rmisc.c
@@ -563,13 +563,15 @@
// this should be as big as the number of functions we pull out.
@@ -74,8 +61,28 @@
#endif
if( hnewlib == NULL ) {
---- NPRQuake-SDL/NPRQuakeSrc/sys_linux.c
-+++ NPRQuake-SDL/NPRQuakeSrc/sys_linux.c
+--- NPRQuakeSrc/Makefile
++++ NPRQuakeSrc/Makefile
+@@ -29,7 +29,7 @@
+
+ CC=gcc
+
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -mcpu=i586 -march=i586 -O6 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
++RELEASE_CFLAGS=$(BASE_CFLAGS) $(OPTFLAGS) -DGENTOO_LIBDIR='\"$(GENTOO_LIBDIR)\"' -DGENTOO_DATADIR='\"$(GENTOO_DATADIR)\"'
+ DEBUG_CFLAGS=$(BASE_CFLAGS) -g
+ LDFLAGS=-lm
+ CFLAGS=$(RELEASE_CFLAGS)
+@@ -176,7 +176,7 @@
+ $(DO_GL_CC)
+
+ $(BUILDDIR)/glquake/common.o : common.c
+- $(DO_GL_DEBUG_CC)
++ $(DO_GL_CC)
+
+ $(BUILDDIR)/glquake/console.o : console.c
+ $(DO_GL_CC)
+--- NPRQuakeSrc/sys_linux.c
++++ NPRQuakeSrc/sys_linux.c
@@ -86,7 +86,7 @@
void Sys_Printf (char *fmt, ...)
{
diff --git a/games-fps/nprquake-sdl/files/nprquake-sdl-1-exec-stack.patch b/games-fps/nprquake-sdl/files/nprquake-sdl-1-exec-stack.patch
new file mode 100644
index 000000000000..99edb83a1b32
--- /dev/null
+++ b/games-fps/nprquake-sdl/files/nprquake-sdl-1-exec-stack.patch
@@ -0,0 +1,36 @@
+--- NPRQuakeSrc/math.s
++++ NPRQuakeSrc/math.s
+@@ -416,3 +416,6 @@
+ call C(BOPS_Error)
+
+ #endif // id386
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- NPRQuakeSrc/snd_mixa.s
++++ NPRQuakeSrc/snd_mixa.s
+@@ -216,3 +216,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- NPRQuakeSrc/sys_dosa.s
++++ NPRQuakeSrc/sys_dosa.s
+@@ -93,3 +93,6 @@
+
+ ret
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- NPRQuakeSrc/worlda.s
++++ NPRQuakeSrc/worlda.s
+@@ -142,3 +142,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild b/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
index 34d729048905..703f2aa300bd 100644
--- a/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
+++ b/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.12 2007/04/09 17:54:20 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.13 2007/07/02 21:46:18 nyhm Exp $
inherit eutils games
@@ -22,16 +22,18 @@ S=${WORKDIR}/NPRQuake-SDL
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ epatch \
+ "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
}
src_compile() {
- make \
+ emake \
GENTOO_LIBDIR="$(games_get_libdir)/${PN}" \
GENTOO_DATADIR="${GAMES_DATADIR}/quake1" \
OPTFLAGS="${CFLAGS}" \
release \
- || die
+ || die "emake failed"
}
src_install() {