summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-10-08 03:24:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-10-08 03:24:18 +0000
commit1cf865653ad0805089ec8f7b3e8657d8512ce957 (patch)
treec34dacd9f527cd2510191c59b448443cb2773175 /games-fps/doom3-hellcampaign
parentStable on amd64, bug #281427 (diff)
downloadgentoo-2-1cf865653ad0805089ec8f7b3e8657d8512ce957.tar.gz
gentoo-2-1cf865653ad0805089ec8f7b3e8657d8512ce957.tar.bz2
gentoo-2-1cf865653ad0805089ec8f7b3e8657d8512ce957.zip
EAPI=2; RESTRICT=fetch
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/doom3-hellcampaign')
-rw-r--r--games-fps/doom3-hellcampaign/ChangeLog8
-rw-r--r--games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild40
2 files changed, 32 insertions, 16 deletions
diff --git a/games-fps/doom3-hellcampaign/ChangeLog b/games-fps/doom3-hellcampaign/ChangeLog
index 44cbed84e934..e556d171f34d 100644
--- a/games-fps/doom3-hellcampaign/ChangeLog
+++ b/games-fps/doom3-hellcampaign/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/doom3-hellcampaign
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-hellcampaign/ChangeLog,v 1.5 2008/02/15 00:36:44 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-hellcampaign/ChangeLog,v 1.6 2009/10/08 03:24:18 nyhm Exp $
+
+ 08 Oct 2009; Tristan Heaven <nyhm@gentoo.org>
+ doom3-hellcampaign-1-r1.ebuild:
+ EAPI=2; RESTRICT=fetch
15 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
-doom3-hellcampaign-1.ebuild, doom3-hellcampaign-1-r1.ebuild:
diff --git a/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild b/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild
index fe110316efa2..83afee6593d1 100644
--- a/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild
+++ b/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild
@@ -1,35 +1,47 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild,v 1.3 2009/10/01 20:54:00 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild,v 1.4 2009/10/08 03:24:18 nyhm Exp $
+
+EAPI=2
MOD_DESC="map pack for Doom 3"
MOD_NAME="Hell Campaign"
MOD_DIR="hell_campaign"
-MOD_BINS="hellcampaign"
inherit games games-mods
HOMEPAGE="http://doom3.filefront.com/file/The_Ultimate_Hell_Campaign;52013"
-SRC_URI="mirror://filefront/Doom_III/Maps/Map_Packs/sp_hc_final.zip
- mirror://filefront/Doom_III/Maps/Map_Packs/hardcorehellcampaign_patch.zip"
+SRC_URI="sp_hc_final.zip
+ hardcorehellcampaign_patch.zip"
LICENSE="as-is"
KEYWORDS="amd64 x86"
IUSE="dedicated opengl"
+RESTRICT="fetch"
-S=${WORKDIR}
+pkg_nofetch() {
+ elog "Please download the following files:"
+ elog "http://www.filefront.com/4445166"
+ elog "http://www.filefront.com/4593578"
+ elog "and move them to ${DISTDIR}"
+}
src_unpack() {
- games-mods_src_unpack
- cd "${S}"
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}
+
+src_prepare() {
+ cd ${MOD_DIR}
# Prevent "non-portable" upper-case-filename warnings in Doom 3
- mv "Hardcore Hell Campaign.pk4" hardcore_hell_campaign.pk4
- mv Q2Textures.pk4 q2Textures.pk4
- mv Q3Textures.pk4 q3Textures.pk4
+ mv -f "Hardcore Hell Campaign.pk4" hardcore_hell_campaign.pk4 || die
+ mv -f Q2Textures.pk4 q2Textures.pk4 || die
+ mv -f Q3Textures.pk4 q3Textures.pk4 || die
+
+ mv -f "Hardcore Hell Campaign.rtf" readme.rtf || die
# Show nice description in "mods" menu within Doom 3
- echo 'Hell Campaign' > description.txt
- mkdir -p ${MOD_DIR}
- mv *.txt *.pk4 ${MOD_DIR} || die
+ echo "${MOD_NAME}" > description.txt
}