summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-05 20:52:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-05 20:52:03 +0000
commitaa5435066a16c1f9af545d4016aa13d36aae9ae3 (patch)
treee7311fc64ba8fa07ac10fe957beabae0a9f44266 /games-fps/alephone
parentStable on hppa. See bug #131135. (diff)
downloadgentoo-2-aa5435066a16c1f9af545d4016aa13d36aae9ae3.tar.gz
gentoo-2-aa5435066a16c1f9af545d4016aa13d36aae9ae3.tar.bz2
gentoo-2-aa5435066a16c1f9af545d4016aa13d36aae9ae3.zip
Fix for gcc-4.1, bug #131689
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/ChangeLog7
-rw-r--r--games-fps/alephone/alephone-20051119.ebuild8
-rw-r--r--games-fps/alephone/files/alephone-20051119-gcc41.patch78
-rw-r--r--games-fps/alephone/files/digest-alephone-200501182
-rw-r--r--games-fps/alephone/files/digest-alephone-200511192
5 files changed, 93 insertions, 4 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index ea8f63342484..fbd9745caa9d 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.8 2006/03/30 01:31:27 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.9 2006/05/05 20:52:03 tupone Exp $
+
+ 05 May 2006; <Tupone@gentoo.org> +files/alephone-20051119-gcc41.patch,
+ alephone-20051119.ebuild:
+ Fix for gcc-4.1, bug #131689 by Charlie Shepherd
+ Patch by Mark Loeser
30 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
-files/20040417-gcc34.patch, -alephone-20040417.ebuild:
diff --git a/games-fps/alephone/alephone-20051119.ebuild b/games-fps/alephone/alephone-20051119.ebuild
index 993051d88312..71380bdf65b8 100644
--- a/games-fps/alephone/alephone-20051119.ebuild
+++ b/games-fps/alephone/alephone-20051119.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20051119.ebuild,v 1.2 2006/03/20 22:07:29 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20051119.ebuild,v 1.3 2006/05/05 20:52:03 tupone Exp $
inherit eutils games
@@ -25,8 +25,10 @@ S=${WORKDIR}/AlephOne-${PV}
src_unpack() {
unpack ${A}
- cp ${FILESDIR}/alephone.png ${S}
- cat > ${S}/alephone.sh << EOF
+ cd "${S}"
+ cp ${FILESDIR}/alephone.png ./
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+ cat > alephone.sh << EOF
#!/bin/sh
DATADIRS="
diff --git a/games-fps/alephone/files/alephone-20051119-gcc41.patch b/games-fps/alephone/files/alephone-20051119-gcc41.patch
new file mode 100644
index 000000000000..4d3712e40179
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20051119-gcc41.patch
@@ -0,0 +1,78 @@
+--- Source_Files/Misc/sdl_widgets.h.old 2006-05-05 22:25:11.000000000 +0200
++++ Source_Files/Misc/sdl_widgets.h 2006-05-05 22:25:55.000000000 +0200
+@@ -944,7 +944,7 @@
+ virtual ~SelectorWidget () {}
+
+ protected:
+- SelectorWidget::SelectorWidget (widget* in_widget)
++ SelectorWidget (widget* in_widget)
+ : SDLWidgetWidget (in_widget)
+ , m_callback (NULL)
+ {}
+@@ -955,7 +955,7 @@
+ class PopupSelectorWidget : public SelectorWidget
+ {
+ public:
+- PopupSelectorWidget::PopupSelectorWidget (w_select_popup* select_popup_w)
++ PopupSelectorWidget (w_select_popup* select_popup_w)
+ : SelectorWidget (select_popup_w)
+ , m_select_popup (select_popup_w)
+ { select_popup_w->set_popup_callback (boost::bind(&PopupSelectorWidget::massage_callback, this, _1), NULL); }
+@@ -974,7 +974,7 @@
+ class SelectSelectorWidget : public SelectorWidget
+ {
+ public:
+- SelectSelectorWidget::SelectSelectorWidget (w_select* select_w)
++ SelectSelectorWidget (w_select* select_w)
+ : SelectorWidget (select_w)
+ , m_select (select_w)
+ { m_select->set_selection_changed_callback (boost::bind(&SelectSelectorWidget::massage_callback, this, _1)); }
+@@ -996,7 +996,7 @@
+ class ColourSelectorWidget : public SelectSelectorWidget
+ {
+ public:
+- ColourSelectorWidget::ColourSelectorWidget (w_player_color* player_color_w)
++ ColourSelectorWidget (w_player_color* player_color_w)
+ : SelectSelectorWidget (player_color_w) {}
+
+ // We ignore the labels and use swatches of colour instead
+@@ -1028,7 +1028,7 @@
+ class StaticTextWidget : public SDLWidgetWidget
+ {
+ public:
+- StaticTextWidget::StaticTextWidget (w_static_text* static_text_w)
++ StaticTextWidget (w_static_text* static_text_w)
+ : SDLWidgetWidget (static_text_w)
+ , m_static_text (static_text_w)
+ {}
+--- Source_Files/TCPMess/CommunicationsChannel.h.old 2006-05-05 22:34:47.000000000 +0200
++++ Source_Files/TCPMess/CommunicationsChannel.h 2006-05-05 22:34:58.000000000 +0200
+@@ -95,7 +95,7 @@
+ // Calls back message handlers (if appropriate)
+ void dispatchIncomingMessages();
+
+- bool CommunicationsChannel::isMessageAvailable();
++ bool isMessageAvailable();
+
+ // Call does not return unless (1) times out (NULL); (2) disconnected (NULL); or
+ // (3) some message received (pointer to inflated message object).
+--- Source_Files/Network/network_dialogs_sdl.cpp.old 2006-05-05 22:38:31.000000000 +0200
++++ Source_Files/Network/network_dialogs_sdl.cpp 2006-05-05 22:39:01.000000000 +0200
+@@ -838,7 +838,7 @@
+ class SdlGatherDialog : public GatherDialog
+ {
+ public:
+- SdlGatherDialog::SdlGatherDialog()
++ SdlGatherDialog()
+ {
+ m_dialog.add(new w_static_text("GATHER NETWORK GAME", TITLE_FONT, TITLE_COLOR));
+
+@@ -921,7 +921,7 @@
+ class SdlJoinDialog : public JoinDialog
+ {
+ public:
+- SdlJoinDialog::SdlJoinDialog()
++ SdlJoinDialog()
+ {
+ m_dialog.add(new w_static_text("JOIN NETWORK GAME", TITLE_FONT, TITLE_COLOR));
+ m_dialog.add(new w_spacer());
diff --git a/games-fps/alephone/files/digest-alephone-20050118 b/games-fps/alephone/files/digest-alephone-20050118
index 9e044d5d5151..e94d26612286 100644
--- a/games-fps/alephone/files/digest-alephone-20050118
+++ b/games-fps/alephone/files/digest-alephone-20050118
@@ -1 +1,3 @@
MD5 789f7fe1f67b60f31aab75bb48ecf552 aleph-20050118.tar.bz2 2324962
+RMD160 663e3923e261a28af1dac6c25f37c44be8e0e941 aleph-20050118.tar.bz2 2324962
+SHA256 5b648a629ecf47474c86147f4a60810b0903ce75895ca2ec7b23439069ea9c0b aleph-20050118.tar.bz2 2324962
diff --git a/games-fps/alephone/files/digest-alephone-20051119 b/games-fps/alephone/files/digest-alephone-20051119
index f750b4136b10..830b80708acf 100644
--- a/games-fps/alephone/files/digest-alephone-20051119
+++ b/games-fps/alephone/files/digest-alephone-20051119
@@ -1 +1,3 @@
MD5 35d42aa80d3d2ab54b5ec5015e5ddcf4 AlephOne-20051119.tar.gz 6519469
+RMD160 0675864a66e0e945e6909291dd3a40fe6af35045 AlephOne-20051119.tar.gz 6519469
+SHA256 0f6dcb1acd153babc3905b18bf460eca7a62a29ba963a812015510d0fa9d9752 AlephOne-20051119.tar.gz 6519469