summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-10 17:11:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-10 17:11:24 +0000
commitaadc7d5eb9877e32672a20191531aa1b67d0490e (patch)
tree6837fc47634132ed1a03d483cb036f2e86813173 /games-engines
parentFixing py deps, thanks to Arfrever for noticing (diff)
downloadgentoo-2-aadc7d5eb9877e32672a20191531aa1b67d0490e.tar.gz
gentoo-2-aadc7d5eb9877e32672a20191531aa1b67d0490e.tar.bz2
gentoo-2-aadc7d5eb9877e32672a20191531aa1b67d0490e.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog8
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.0.0_rc1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index d4f03486099c..52b20196a745 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.26 2009/08/02 00:02:37 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.27 2009/09/10 17:11:24 mr_bones_ Exp $
+
+*scummvm-tools-1.0.0_rc1 (10 Sep 2009)
+
+ 10 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-tools-1.0.0_rc1.ebuild:
+ version bump
01 Aug 2009; <chainsaw@gentoo.org> scummvm-tools-0.13.0.ebuild:
Marked stable on AMD64 as requested by Michael "Mr. Bones" Sterrett
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.0.0_rc1.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.0.0_rc1.ebuild
new file mode 100644
index 000000000000..2966cb2dfbc7
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-1.0.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.0.0_rc1.ebuild,v 1.1 2009/09/10 17:11:24 mr_bones_ Exp $
+
+EAPI=2
+WX_GTK_VER=2.8
+inherit toolchain-funcs wxwidgets games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/flac
+ media-libs/libvorbis
+ x11-libs/wxGTK:2.8"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ rm -f *.bat
+ sed -ri \
+ -e '/^(CC|CXX)\b/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ local f
+ for f in $(find . -type f -perm +1 -print); do
+ newgamesbin $f ${PN}-${f##*/} || die "newgamesbin $f failed"
+ done
+ dodoc README TODO
+ prepgamesdirs
+}