summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 06:49:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 06:49:50 +0000
commit8faee84fba9cb21ef5b432af4ed1619f65c9415d (patch)
treedee67458eec24c884b07871315d5f21058a4d23c /games-engines
parentVersion bump. Remove missing file from dodoc arguments, bug 256683. (diff)
downloadgentoo-2-8faee84fba9cb21ef5b432af4ed1619f65c9415d.tar.gz
gentoo-2-8faee84fba9cb21ef5b432af4ed1619f65c9415d.tar.bz2
gentoo-2-8faee84fba9cb21ef5b432af4ed1619f65c9415d.zip
EAPI=2; respect CC
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/frotz/ChangeLog7
-rw-r--r--games-engines/frotz/frotz-2.43.ebuild16
2 files changed, 17 insertions, 6 deletions
diff --git a/games-engines/frotz/ChangeLog b/games-engines/frotz/ChangeLog
index ec3878d191d5..623bd4deb1f4 100644
--- a/games-engines/frotz/ChangeLog
+++ b/games-engines/frotz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/frotz
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/ChangeLog,v 1.13 2008/02/06 20:08:41 grobian Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/ChangeLog,v 1.14 2009/01/30 06:49:50 mr_bones_ Exp $
+
+ 30 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> frotz-2.43.ebuild:
+ EAPI=2; respect CC
06 Feb 2008; Fabian Groffen <grobian@gentoo.org> frotz-2.43.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/games-engines/frotz/frotz-2.43.ebuild b/games-engines/frotz/frotz-2.43.ebuild
index 4fa73f4da6c7..995a740609ef 100644
--- a/games-engines/frotz/frotz-2.43.ebuild
+++ b/games-engines/frotz/frotz-2.43.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.15 2008/02/06 20:08:41 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.16 2009/01/30 06:49:50 mr_bones_ Exp $
-inherit toolchain-funcs games
+EAPI=2
+inherit games
DESCRIPTION="Curses based interpreter for Z-code based text games"
HOMEPAGE="http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
@@ -16,8 +17,15 @@ IUSE="alsa oss"
DEPEND="sys-libs/ncurses
alsa? ( oss? ( media-libs/alsa-oss ) )"
+src_prepare() {
+ sed -i \
+ -e '/^CC /d' \
+ Makefile \
+ || die 'sed failed'
+}
+
src_compile() {
- local OPTS="CC=$(tc-getcc) CONFIG_DIR=${GAMES_SYSCONFDIR}"
+ local OPTS="CONFIG_DIR=${GAMES_SYSCONFDIR}"
use oss && OPTS="${MAKE_OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
emake ${MAKE_OPTS} all || die "emake failed"
}