summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-22 16:33:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-22 16:33:40 +0000
commit5fdb9ac2c28cbac97a84c9d0da9fc7a14a255c0e (patch)
tree98633a807315f4242606a720e9bd5e20cd984b0b /games-engines
parentStable on IA64. (diff)
downloadgentoo-2-5fdb9ac2c28cbac97a84c9d0da9fc7a14a255c0e.tar.gz
gentoo-2-5fdb9ac2c28cbac97a84c9d0da9fc7a14a255c0e.tar.bz2
gentoo-2-5fdb9ac2c28cbac97a84c9d0da9fc7a14a255c0e.zip
tidy
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/gargoyle/gargoyle-20060917.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/games-engines/gargoyle/gargoyle-20060917.ebuild b/games-engines/gargoyle/gargoyle-20060917.ebuild
index 9cab86758649..3f4ecdf899f6 100644
--- a/games-engines/gargoyle/gargoyle-20060917.ebuild
+++ b/games-engines/gargoyle/gargoyle-20060917.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917.ebuild,v 1.1 2007/01/22 10:59:52 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917.ebuild,v 1.2 2007/01/22 16:33:40 mr_bones_ Exp $
inherit eutils
MY_PV="2006-09-17"
MY_P=${PN}-${MY_PV}
-S="${WORKDIR}/${PN}/"
DESCRIPTION="Beautified Glk library and interactive fiction multi-interpreter"
HOMEPAGE="http://ccxvii.net/gargoyle/"
SRC_URI="http://ccxvii.net/gargoyle/download/${MY_P}-source.zip"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
RDEPEND=">=media-libs/freetype-2.1.9-r1
>=x11-libs/gtk+-2.10.6
>=dev-libs/glib-2.12.4-r1
@@ -26,37 +27,40 @@ RDEPEND=">=media-libs/freetype-2.1.9-r1
DEPEND="${RDEPEND}
>=dev-util/jam-2.5-r3
- app-arch/unzip
- >=sys-apps/sed-4.1.4-r1"
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
-src_unpack()
-{
+src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
#Fix file named
- epatch ${FILESDIR}/filename-friendliness-${PV}.patch
+ epatch "${FILESDIR}"/filename-friendliness-${PV}.patch
#Fix gtk+ detection
- sed -i 's/"pkg-config freetype2 gtk+"/"pkg-config freetype2 gtk+-2.0"/' ${S}/Jamrules
+ sed -i \
+ -e 's/"pkg-config freetype2 gtk+"/"pkg-config freetype2 gtk+-2.0"/' \
+ Jamrules \
+ || die "sed failed"
}
-src_compile()
-{
- jam
+src_compile() {
+ jam || die "jam failed"
}
-src_install()
-{
+src_install() {
dodoc Readme.txt garglk/TODO licenses/*
- insinto /etc; newins garglk/garglk.ini garglk.ini
+ insinto /etc
+ newins garglk/garglk.ini garglk.ini
#Should to copy garglk/garglk.ini to /etc/, but I don't know the syntax
cd build/linux.release
dolib garglk/libgarglk.so
- dobin advsys/gargoyle-advsys agility/gargoyle-agility alan2/gargoyle-alan2
- dobin alan3/gargoyle-alan3 garglk/gargoyle git/gargoyle-git
- dobin hugo/gargoyle-hugo level9/gargoyle-level9 scare/gargoyle-scare
- dobin tads/gargoyle-tadsr frotz/gargoyle-frotz magnetic/gargoyle-magnetic
+ dobin \
+ advsys/gargoyle-advsys agility/gargoyle-agility alan2/gargoyle-alan2 \
+ alan3/gargoyle-alan3 garglk/gargoyle git/gargoyle-git \
+ hugo/gargoyle-hugo level9/gargoyle-level9 scare/gargoyle-scare \
+ tads/gargoyle-tadsr frotz/gargoyle-frotz magnetic/gargoyle-magnetic
}