summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-01 19:01:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-01 19:01:40 +0000
commit1713fa2787c39449880992b22ac90de46dbffbc4 (patch)
treee117a2302ccc02a83db82ed60372008567c31a38 /games-engines
parentVersion bump. Add a Main Category to the desktop entry. Fixes bug #275697. (diff)
downloadgentoo-2-1713fa2787c39449880992b22ac90de46dbffbc4.tar.gz
gentoo-2-1713fa2787c39449880992b22ac90de46dbffbc4.tar.bz2
gentoo-2-1713fa2787c39449880992b22ac90de46dbffbc4.zip
zlib is required
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog6
-rw-r--r--games-engines/scummvm/scummvm-0.13.1.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 70c3c99635e9..a9de2de48f1e 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.70 2009/05/26 06:48:38 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.71 2009/07/01 19:01:40 mr_bones_ Exp $
+
+ 01 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ scummvm-0.13.1.ebuild:
+ zlib is required
25 May 2009; Alfredo Tupone <tupone@gentoo.org>
+files/scummvm-0.13.1-glibc210.patch, scummvm-0.13.1.ebuild:
diff --git a/games-engines/scummvm/scummvm-0.13.1.ebuild b/games-engines/scummvm/scummvm-0.13.1.ebuild
index 9ef6f561790e..015725bf1e88 100644
--- a/games-engines/scummvm/scummvm-0.13.1.ebuild
+++ b/games-engines/scummvm/scummvm-0.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.13.1.ebuild,v 1.2 2009/05/25 13:42:31 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.13.1.ebuild,v 1.3 2009/07/01 19:01:40 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -12,18 +12,18 @@ SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa debug flac fluidsynth mp3 ogg vorbis zlib"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND=">=media-libs/libsdl-1.2.2
>media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
ogg? ( media-libs/libogg media-libs/libvorbis )
vorbis? ( media-libs/libogg media-libs/libvorbis )
alsa? ( >=media-libs/alsa-lib-0.9[midi] )
mp3? ( media-libs/libmad )
flac? ( media-libs/flac )
- fluidsynth? ( media-sound/fluidsynth )
- zlib? ( sys-libs/zlib )"
+ fluidsynth? ( media-sound/fluidsynth )"
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
@@ -62,11 +62,11 @@ src_configure() {
--bindir="${GAMES_BINDIR}" \
--datadir="${GAMES_DATADIR}" \
--libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
$(use_enable debug) \
$(use_enable alsa) \
$(use_enable mp3 mad) \
$(use_enable flac) \
- $(use_enable zlib) \
$(use_enable x86 nasm) \
${myconf} \
|| die "configure failed"