summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-01 03:18:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-01 03:18:31 +0000
commit98f87426a356d095f6c9c2823c8b2a1e95b06e04 (patch)
tree524eedf3c5c01877355f43de60b49679a0db685c /games-engines/scummvm
parentdont delete inttypes.m4 #104339 by Ron (diff)
downloadgentoo-2-98f87426a356d095f6c9c2823c8b2a1e95b06e04.tar.gz
gentoo-2-98f87426a356d095f6c9c2823c8b2a1e95b06e04.tar.bz2
gentoo-2-98f87426a356d095f6c9c2823c8b2a1e95b06e04.zip
Add a patch for 64bit issues #103450 by Ian Kumlien.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/files/scummvm-0.7.1-64bit.patch35
-rw-r--r--games-engines/scummvm/scummvm-0.7.1.ebuild5
3 files changed, 44 insertions, 4 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 4ad053a47896..b9df0dee5c81 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.24 2005/05/12 01:57:45 mr_bones_ Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.25 2005/09/01 03:18:31 vapier Exp $
+
+ 01 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/scummvm-0.7.1-64bit.patch, scummvm-0.7.1.ebuild:
+ Add a patch for 64bit issues #103450 by Ian Kumlien.
12 May 2005; Michael Sterrett <mr_bones_@gentoo.org>
-files/0.7.0-configure.patch, -scummvm-0.7.0.ebuild:
diff --git a/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch b/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch
new file mode 100644
index 000000000000..224b7106718d
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch
@@ -0,0 +1,35 @@
+Fixes for 64bit issues from upstream.
+
+http://bugs.gentoo.org/103450
+
+--- scummvm/scummvm/common/scaler.cpp
++++ scummvm/scummvm/common/scaler.cpp
+@@ -123,7 +123,7 @@
+ int width, int height) {
+ uint8 *r;
+
+- assert(((int)dstPtr & 3) == 0);
++ assert(((long)dstPtr & 3) == 0);
+ while (height--) {
+ r = dstPtr;
+ for (int i = 0; i < width; ++i, r += 4) {
+@@ -148,7 +148,7 @@
+ const uint32 dstPitch2 = dstPitch * 2;
+ const uint32 dstPitch3 = dstPitch * 3;
+
+- assert(((int)dstPtr & 1) == 0);
++ assert(((long)dstPtr & 1) == 0);
+ while (height--) {
+ r = dstPtr;
+ for (int i = 0; i < width; ++i, r += 6) {
+--- scummvm/scummvm/scumm/instrument.h
++++ scummvm/scummvm/scumm/instrument.h
+@@ -60,7 +60,7 @@
+
+ void clear();
+ void copy_to (Instrument *dest) { if (_instrument) _instrument->copy_to (dest); else dest->clear(); }
+- operator int() { return (_instrument ? (int) _instrument : 255); }
++ operator int() { return (_instrument ? (long) _instrument : 255); }
+ void program (byte program, bool mt32);
+ void adlib (byte *instrument);
+ void roland (byte *instrument);
diff --git a/games-engines/scummvm/scummvm-0.7.1.ebuild b/games-engines/scummvm/scummvm-0.7.1.ebuild
index 3d40b6994ed1..bd49fda07aff 100644
--- a/games-engines/scummvm/scummvm-0.7.1.ebuild
+++ b/games-engines/scummvm/scummvm-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.1.ebuild,v 1.4 2005/06/23 00:54:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.1.ebuild,v 1.5 2005/09/01 03:18:31 vapier Exp $
inherit eutils games
@@ -28,7 +28,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-configure.patch"
+ epatch "${FILESDIR}"/${PV}-configure.patch
+ epatch "${FILESDIR}"/${P}-64bit.patch
}
src_compile() {