summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-07-02 18:59:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-07-02 18:59:56 +0000
commitad1ea6fcba5c53fcdf012e675b46cf2b1cd49ae3 (patch)
treece3fdd18259ae0ed9a6576713d8215af55461405 /games-emulation
parentRemove old. (diff)
downloadgentoo-2-ad1ea6fcba5c53fcdf012e675b46cf2b1cd49ae3.tar.gz
gentoo-2-ad1ea6fcba5c53fcdf012e675b46cf2b1cd49ae3.tar.bz2
gentoo-2-ad1ea6fcba5c53fcdf012e675b46cf2b1cd49ae3.zip
version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.9.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 559fc1930caa..0479b1ab0a4c 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.78 2013/02/17 17:40:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.79 2013/07/02 18:59:56 mr_bones_ Exp $
+
+*stella-3.9 (02 Jul 2013)
+
+ 02 Jul 2013; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.9.ebuild:
+ version bump
17 Feb 2013; Agostino Sarubbo <ago@gentoo.org> stella-3.7.5.ebuild:
Stable for x86, wrt bug #455522
diff --git a/games-emulation/stella/stella-3.9.ebuild b/games-emulation/stella/stella-3.9.ebuild
new file mode 100644
index 000000000000..aa0efa29bee8
--- /dev/null
+++ b/games-emulation/stella/stella-3.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.9.ebuild,v 1.1 2013/07/02 18:59:56 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,opengl?,video]
+ x11-libs/libX11
+ media-libs/libpng:0
+ sys-libs/zlib
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ emake DESTDIR="${D}" install || die
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}