summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-06 05:47:54 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-06 05:47:54 +0000
commit99fa74da71582e50874a840d6d93e511211ab678 (patch)
treebf13136a182d88e83f011c6eb8c2693e9922152d /games-emulation
parentuse games_get_libdir (diff)
downloadgentoo-2-99fa74da71582e50874a840d6d93e511211ab678.tar.gz
gentoo-2-99fa74da71582e50874a840d6d93e511211ab678.tar.bz2
gentoo-2-99fa74da71582e50874a840d6d93e511211ab678.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx/pcsx-1.5-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-emulation/pcsx/pcsx-1.5-r1.ebuild b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
index 9e3fdfc637b8..2e0fbf6490d8 100644
--- a/games-emulation/pcsx/pcsx-1.5-r1.ebuild
+++ b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.10 2007/02/24 00:53:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.11 2007/04/06 05:47:54 nyhm Exp $
inherit eutils games
@@ -36,14 +36,14 @@ src_unpack() {
"${FILESDIR}"/${PV}-gentoo.patch \
"${FILESDIR}"/${P}-gcc41.patch
sed -i \
- -e "s:Plugin/:${GAMES_LIBDIR}/psemu/plugins/:" \
- -e "s:Bios/:${GAMES_LIBDIR}/psemu/bios/:" \
+ -e "s:Plugin/:$(games_get_libdir)/psemu/plugins/:" \
+ -e "s:Bios/:$(games_get_libdir)/psemu/bios/:" \
-e 's:Pcsx.cfg:~/.pcsx/config:' \
Linux/LnxMain.c \
|| die "sed LnxMain.c failed"
sed \
-e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
- -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
"${FILESDIR}"/pcsx > "${T}"/pcsx \
|| die "sed failed"