summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-22 16:55:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-22 16:55:18 +0000
commit73598f2ad776e8af324640ab7c46b2659ae2636c (patch)
tree74e745f227742c193a5fcbeef7ef6d7b5ff8f65f /games-emulation
parentVersion bump. (diff)
downloadgentoo-2-73598f2ad776e8af324640ab7c46b2659ae2636c.tar.gz
gentoo-2-73598f2ad776e8af324640ab7c46b2659ae2636c.tar.bz2
gentoo-2-73598f2ad776e8af324640ab7c46b2659ae2636c.zip
hide non-PIC asm behind pic USE flag (bug #539656)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yabause/ChangeLog6
-rw-r--r--games-emulation/yabause/metadata.xml3
-rw-r--r--games-emulation/yabause/yabause-0.9.14.ebuild5
3 files changed, 11 insertions, 3 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index b86c7eb5f428..65d58cc4d069 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/yabause
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.43 2015/03/26 22:30:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.44 2015/05/22 16:55:18 mr_bones_ Exp $
+
+ 22 May 2015; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ yabause-0.9.14.ebuild:
+ hide non-PIC asm behind pic USE flag (bug #539656)
26 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> -yabause-0.9.10.ebuild:
old
diff --git a/games-emulation/yabause/metadata.xml b/games-emulation/yabause/metadata.xml
index cad5a2aa1773..9d7d3de7f1a1 100644
--- a/games-emulation/yabause/metadata.xml
+++ b/games-emulation/yabause/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+ <use>
+ <flag name='pic'>disable optimized assembly code that is not PIC friendly</flag>
+ </use>
</pkgmetadata>
diff --git a/games-emulation/yabause/yabause-0.9.14.ebuild b/games-emulation/yabause/yabause-0.9.14.ebuild
index b0ce74f92c79..7587b8c9eff1 100644
--- a/games-emulation/yabause/yabause-0.9.14.ebuild
+++ b/games-emulation/yabause/yabause-0.9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.14.ebuild,v 1.3 2015/03/25 13:48:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.14.ebuild,v 1.4 2015/05/22 16:55:18 mr_bones_ Exp $
EAPI=5
inherit eutils cmake-utils games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="openal opengl qt5 sdl"
+IUSE="openal opengl pic qt5 sdl"
# x11-libs/libXrandr is an automagic dep
# qt5 over qt4 and libsdl2 over libsdl is
@@ -53,6 +53,7 @@ src_configure() {
$(cmake-utils_use sdl YAB_WANT_SDL)
$(cmake-utils_use openal YAB_WANT_OPENAL)
$(cmake-utils_use opengl YAB_WANT_OPENGL)
+ $(cmake-utils_use !pic SH2_DYNAREC)
-DYAB_PORTS=$(usex qt5 "qt" "gtk")
)
cmake-utils_src_configure