summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-30 02:45:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-30 02:45:30 +0000
commit6dc509fbc17670140ba6f2a707efd2a6bf6671c7 (patch)
tree2cc48c59b07d448e0efb1c281a302be9b969d7d3 /games-emulation
parentMarking perl-tk-804.029 ppc for bug 333573 (diff)
downloadgentoo-2-6dc509fbc17670140ba6f2a707efd2a6bf6671c7.tar.gz
gentoo-2-6dc509fbc17670140ba6f2a707efd2a6bf6671c7.tar.bz2
gentoo-2-6dc509fbc17670140ba6f2a707efd2a6bf6671c7.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.2.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 2578a5783073..a9b81632fe15 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.50 2010/08/28 02:35:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.51 2010/09/30 02:45:30 mr_bones_ Exp $
+
+*stella-3.2.2 (30 Sep 2010)
+
+ 30 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.2.2.ebuild:
+ version bump
*stella-3.2.1 (28 Aug 2010)
diff --git a/games-emulation/stella/stella-3.2.2.ebuild b/games-emulation/stella/stella-3.2.2.ebuild
new file mode 100644
index 000000000000..f73264ed19b9
--- /dev/null
+++ b/games-emulation/stella/stella-3.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.2.2.ebuild,v 1.1 2010/09/30 02:45:30 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl[video]
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}