summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-06 05:42:40 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-06 05:42:40 +0000
commit598347ba48a161f1800c69b501280c6b97a09ebd (patch)
tree28372e6075e1496ddae2972be199260dbc3b8b76 /games-emulation
parentBump to 2.0RC4. 965GM support and several fixes. (diff)
downloadgentoo-2-598347ba48a161f1800c69b501280c6b97a09ebd.tar.gz
gentoo-2-598347ba48a161f1800c69b501280c6b97a09ebd.tar.bz2
gentoo-2-598347ba48a161f1800c69b501280c6b97a09ebd.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
index 3294d0aa5e0d..28400e0f50a9 100644
--- a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
+++ b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.9 2007/02/22 05:23:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.10 2007/04/06 05:42:40 nyhm Exp $
inherit flag-o-matic eutils games
@@ -25,11 +25,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-compile.patch" \
- "${FILESDIR}/${P}-inifix.patch" \
- "${FILESDIR}/${P}-gtk2.patch"
+ epatch \
+ "${FILESDIR}"/${P}-compile.patch \
+ "${FILESDIR}"/${P}-inifix.patch \
+ "${FILESDIR}"/${P}-gtk2.patch
- make clean || die "couldn't clean"
+ emake -j1 clean
# gcc 3.4 at least has a problem with -O3 and inline asm
replace-flags -O3 -O2
@@ -38,7 +39,7 @@ src_unpack() {
sed -i \
-e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" \
Makefile \
- || die "sed failed"
+ || die "sed failed"
}
src_compile() {
@@ -46,9 +47,9 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+ exeinto "$(games_get_libdir)"/mupen64/plugins
doexe Glide64.so || die "doexe failed"
- insinto "${GAMES_LIBDIR}/mupen64/plugins"
- doins Glide64.ini
+ insinto "$(games_get_libdir)"/mupen64/plugins
+ doins Glide64.ini || die "doins failed"
prepgamesdirs
}