summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:53 +0000
commit203364cb29c8ef619ebf209fe6362e6047176a10 (patch)
tree7f683dc966970a9270a156f299bd0296e2cbcdff /games-emulation
parentRemove implicit CPU flags from the Makefiles. Support epatch_user. (diff)
downloadgentoo-2-203364cb29c8ef619ebf209fe6362e6047176a10.tar.gz
gentoo-2-203364cb29c8ef619ebf209fe6362e6047176a10.tar.bz2
gentoo-2-203364cb29c8ef619ebf209fe6362e6047176a10.zip
Remove implicit CPU flags from the Makefiles. Support epatch_user.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-ui-console/ChangeLog6
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild9
2 files changed, 13 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-ui-console/ChangeLog b/games-emulation/mupen64plus-ui-console/ChangeLog
index a8495fbfc634..53d80c41940a 100644
--- a/games-emulation/mupen64plus-ui-console/ChangeLog
+++ b/games-emulation/mupen64plus-ui-console/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64plus-ui-console
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/ChangeLog,v 1.1 2013/12/15 12:12:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/ChangeLog,v 1.2 2013/12/16 16:41:53 mgorny Exp $
+
+ 16 Dec 2013; Michał Górny <mgorny@gentoo.org>
+ mupen64plus-ui-console-2.0.ebuild:
+ Remove implicit CPU flags from the Makefiles. Support epatch_user.
*mupen64plus-ui-console-2.0 (15 Dec 2013)
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild
index cc21a34482a1..549373feff34 100644
--- a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild,v 1.1 2013/12/15 12:12:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild,v 1.2 2013/12/16 16:41:53 mgorny Exp $
EAPI=5
@@ -24,6 +24,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages