summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-11 23:53:29 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-11 23:53:29 +0000
commitd9f8accbbb10f650821efd52462d48d46446a467 (patch)
tree5b2d03ccc7d5f95d41d257118a4f37658a0490f2 /games-emulation/yabause
parentRemove dead version and move imake to DEPEND, fixing bug #221431 (diff)
downloadgentoo-2-d9f8accbbb10f650821efd52462d48d46446a467.tar.gz
gentoo-2-d9f8accbbb10f650821efd52462d48d46446a467.tar.bz2
gentoo-2-d9f8accbbb10f650821efd52462d48d46446a467.zip
Version bump
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'games-emulation/yabause')
-rw-r--r--games-emulation/yabause/ChangeLog7
-rw-r--r--games-emulation/yabause/yabause-0.9.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index ed4bdb5253bc..e5506d53986c 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/yabause
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.24 2008/05/08 19:25:54 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.25 2008/05/11 23:53:29 nyhm Exp $
+
+*yabause-0.9.5 (11 May 2008)
+
+ 11 May 2008; Tristan Heaven <nyhm@gentoo.org> +yabause-0.9.5.ebuild:
+ Version bump
*yabause-0.9.4 (08 May 2008)
diff --git a/games-emulation/yabause/yabause-0.9.5.ebuild b/games-emulation/yabause/yabause-0.9.5.ebuild
new file mode 100644
index 000000000000..854cffd7557a
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.5.ebuild,v 1.1 2008/05/11 23:53:29 nyhm Exp $
+
+inherit autotools games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-2*
+ x11-libs/gtkglext
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ media-libs/libsdl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/src/c68k
+ sed -i \
+ -e 's/nodist_pkgdata/noinst/' \
+ Makefile.am \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --datadir=/usr/share \
+ --with-port=gtk \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog GOALS README README.LIN TODO
+ prepgamesdirs
+}