summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-11 22:27:52 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-11 22:27:52 +0000
commit4427f9308bb7ef02549e81866418577df4fdc0fa (patch)
tree7431b5b7326990a0774ede50a15befef2e7c59e4 /games-emulation/visualboyadvance
parentVersion bump. (diff)
downloadgentoo-2-4427f9308bb7ef02549e81866418577df4fdc0fa.tar.gz
gentoo-2-4427f9308bb7ef02549e81866418577df4fdc0fa.tar.bz2
gentoo-2-4427f9308bb7ef02549e81866418577df4fdc0fa.zip
Install desktop entry, bug #157527
(Portage version: 2.1.2_rc3-r1)
Diffstat (limited to 'games-emulation/visualboyadvance')
-rw-r--r--games-emulation/visualboyadvance/ChangeLog6
-rw-r--r--games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild40
2 files changed, 36 insertions, 10 deletions
diff --git a/games-emulation/visualboyadvance/ChangeLog b/games-emulation/visualboyadvance/ChangeLog
index 19b860613884..35ef4493aae4 100644
--- a/games-emulation/visualboyadvance/ChangeLog
+++ b/games-emulation/visualboyadvance/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/visualboyadvance
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/ChangeLog,v 1.29 2006/10/13 17:12:32 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/ChangeLog,v 1.30 2006/12/11 22:27:52 nyhm Exp $
+
+ 11 Dec 2006; Tristan Heaven <nyhm@gentoo.org>
+ visualboyadvance-1.7.2-r1.ebuild:
+ Install desktop entry, bug #157527
13 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+files/1.7.2-gcc41.patch:
diff --git a/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
index ceea2055fee8..359bb9274009 100644
--- a/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
+++ b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild,v 1.10 2006/10/18 23:19:44 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild,v 1.11 2006/12/11 22:27:52 nyhm Exp $
inherit eutils flag-o-matic games
@@ -11,27 +11,43 @@ SRC_URI="mirror://sourceforge/vba/VisualBoyAdvance-src-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="mmx gtk"
+IUSE="gtk mmx nls"
RDEPEND="media-libs/libpng
- sys-libs/zlib
media-libs/libsdl
gtk? (
>=x11-libs/gtk+-2.4
>=dev-cpp/gtkmm-2.4
>=dev-cpp/libglademm-2.4
- )"
+ )
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- mmx? ( dev-lang/nasm )"
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )
+ nls? ( sys-devel/gettext )"
S=${WORKDIR}/VisualBoyAdvance-${PV}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-homedir.patch"
- epatch "${FILESDIR}/${PV}-gcc34.patch"
- epatch "${FILESDIR}/${PV}-gcc41.patch"
+
+ sed -i \
+ -e 's:$(localedir):/usr/share/locale:' \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ $(find . -name 'Makefile.in*') \
+ || die "sed failed"
+
+ cat >> src/i386/2xSaImmx.asm <<-EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+ EOF
+
+ epatch \
+ "${FILESDIR}"/${PV}-homedir.patch \
+ "${FILESDIR}"/${PV}-gcc34.patch \
+ "${FILESDIR}"/${PV}-gcc41.patch
}
src_compile() {
@@ -40,14 +56,20 @@ src_compile() {
# Removed --enable-c-core as it *should* determine this based on arch
egamesconf \
+ --disable-dependency-tracking \
$(use_with mmx) \
$(use_enable gtk gtk 2.4) \
+ $(use_enable nls) \
|| die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README README-win.txt
+ if use gtk ; then
+ newicon src/gtk/images/vba-64.png ${PN}.png
+ make_desktop_entry gvba VisualBoyAdvance
+ fi
prepgamesdirs
}