summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-09 17:26:23 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-09 17:26:23 +0000
commit0a8c9f27adae83d840e9e5df0946ab417413e14b (patch)
tree6e75ce88b6432574c52a4bade835c2e28cea4241 /games-emulation/psemu-peopsspu
parentx86 stable wrt bug 173876 (diff)
downloadgentoo-2-0a8c9f27adae83d840e9e5df0946ab417413e14b.tar.gz
gentoo-2-0a8c9f27adae83d840e9e5df0946ab417413e14b.tar.bz2
gentoo-2-0a8c9f27adae83d840e9e5df0946ab417413e14b.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-emulation/psemu-peopsspu')
-rw-r--r--games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild b/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
index 52cdbaeb0f46..2325d2b01bc0 100644
--- a/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
+++ b/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild,v 1.2 2006/12/06 17:18:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild,v 1.3 2007/04/09 17:26:23 nyhm Exp $
-inherit eutils games
+inherit autotools eutils games
DESCRIPTION="P.E.Op.S Sound Emulation (SPU) PSEmu Plugin"
HOMEPAGE="http://sourceforge.net/projects/peops/"
@@ -19,7 +19,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
DEPEND="${RDEPEND}
sys-devel/automake"
-S="${WORKDIR}"
+S=${WORKDIR}
src_unpack() {
unpack ${A}
@@ -31,22 +31,22 @@ src_unpack() {
|| die "sed Makefile failed"
cd linuxcfg
- tar -zxf spucfg.tar.gz || die "unpack linuxcfg"
- make maintainer-clean || die "distclean linuxcfg"
+ unpack ./spucfg.tar.gz
+ emake maintainer-clean || die "distclean linuxcfg"
rm -f {,src/}Makefile.in aclocal.m4 configure
- edos2unix `find -name '*.[ch]'` *.in
- aclocal && automake -a -c && autoconf || die "could not autotool"
+ edos2unix $(find -name '*.[ch]') *.in
+ eautoreconf
}
src_compile() {
cd src
if use oss || ! use alsa; then
- make clean || die "oss clean"
+ emake clean || die "oss clean"
emake USEALSA=FALSE || die "oss build"
mv libspu* ..
fi
if use alsa ; then
- make clean || die "alsa clean"
+ emake clean || die "alsa clean"
emake USEALSA=TRUE || die "alsa build"
mv libspu* ..
fi
@@ -58,12 +58,12 @@ src_compile() {
}
src_install() {
- exeinto ${GAMES_LIBDIR}/psemu/plugins
+ exeinto "$(games_get_libdir)"/psemu/plugins
doexe libspu* || die "doexe plugins"
- exeinto ${GAMES_LIBDIR}/psemu/cfg
+ exeinto "$(games_get_libdir)"/psemu/cfg
doexe cfgPeopsOSS || die "doexe cfg"
- insinto ${GAMES_LIBDIR}/psemu/cfg
- doins spuPeopsOSS.cfg
+ insinto "$(games_get_libdir)"/psemu/cfg
+ doins spuPeopsOSS.cfg || die "doins failed"
dodoc src/*.txt *.txt
prepgamesdirs
}