summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-12 22:10:51 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-12 22:10:51 +0000
commitdeccacb5af480548de6f66629c5c6b029e8921b5 (patch)
treedee997957aa9ae596f8c2c967047be6205a53d87 /games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
parentinital ebuild (diff)
downloadgentoo-2-deccacb5af480548de6f66629c5c6b029e8921b5.tar.gz
gentoo-2-deccacb5af480548de6f66629c5c6b029e8921b5.tar.bz2
gentoo-2-deccacb5af480548de6f66629c5c6b029e8921b5.zip
ver bump
Diffstat (limited to 'games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild')
-rw-r--r--games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
new file mode 100644
index 000000000000..e2b039196342
--- /dev/null
+++ b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild,v 1.1 2003/12/12 22:06:52 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 CD/DVD iso plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.5release/CDVDiso${PV}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/CDVDiso
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/src/Linux/Makefile
+}
+
+src_compile() {
+ cd src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd src/Linux
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ newexe libCDVDiso.so libCDVDiso-${PV}.so
+ exeinto ${GAMES_LIBDIR}/ps2emu/cfg
+ doexe cfgCDVDiso
+ prepgamesdirs
+}