summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-15 12:12:27 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-15 12:12:27 +0000
commit18c985e56efe098c6a4eb848222a826ba5e6abd4 (patch)
treeae41767fcd1a065c53dffa48456e0c109e6f31dd /games-emulation/mupen64plus-ui-console
parent<=net-libs/opal-2.2.11 removal (pending 11 July 2013), see #290062 and #29006... (diff)
downloadgentoo-2-18c985e56efe098c6a4eb848222a826ba5e6abd4.tar.gz
gentoo-2-18c985e56efe098c6a4eb848222a826ba5e6abd4.tar.bz2
gentoo-2-18c985e56efe098c6a4eb848222a826ba5e6abd4.zip
Introduce the console UI for mupen64plus-2.0.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation/mupen64plus-ui-console')
-rw-r--r--games-emulation/mupen64plus-ui-console/ChangeLog9
-rw-r--r--games-emulation/mupen64plus-ui-console/metadata.xml13
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild76
3 files changed, 98 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-ui-console/ChangeLog b/games-emulation/mupen64plus-ui-console/ChangeLog
new file mode 100644
index 000000000000..a8495fbfc634
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-emulation/mupen64plus-ui-console
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/ChangeLog,v 1.1 2013/12/15 12:12:27 mgorny Exp $
+
+*mupen64plus-ui-console-2.0 (15 Dec 2013)
+
+ 15 Dec 2013; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +mupen64plus-ui-console-2.0.ebuild:
+ Introduce the console UI for mupen64plus-2.0.
diff --git a/games-emulation/mupen64plus-ui-console/metadata.xml b/games-emulation/mupen64plus-ui-console/metadata.xml
new file mode 100644
index 000000000000..9047711e4ffd
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer>
+ <email>joker@gentoo.org</email>
+ <name>Christian Birchinger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild
new file mode 100644
index 000000000000..cc21a34482a1
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.0.ebuild,v 1.1 2013/12/15 12:12:27 mgorny Exp $
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
+HOMEPAGE="http://code.google.com/p/mupen64plus/"
+SRC_URI="mirror://bitbucket/richard42/${PN}/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-emulation/mupen64plus-core:0=
+ media-libs/libsdl:0=
+ !<games-emulation/mupen64plus-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ BINDIR="${GAMES_BINDIR}"
+ LIBDIR="$(games_get_libdir)"
+ COREDIR="$(games_get_libdir)/"
+ PLUGINDIR="$(games_get_libdir)"/mupen64plus
+ SHAREDIR="${GAMES_DATADIR}"/mupen64plus
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+ prepgamesdirs
+}