summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-24 00:35:19 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-24 00:35:19 +0000
commitfa4f93401842189d7ab9ab87f135de23a027a4b5 (patch)
treecefa877e66e695edf4846f69220cbf50dd65102b /games-emulation/mupen64/files
parentfix for apple gcc-4.0 on ppc-macos (diff)
downloadgentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.tar.gz
gentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.tar.bz2
gentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.zip
adding amd64
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/mupen64/files')
-rw-r--r--games-emulation/mupen64/files/mupen64-gtk2-makefile.patch12
-rw-r--r--games-emulation/mupen64/files/mupen64-makefiles.patch8
2 files changed, 10 insertions, 10 deletions
diff --git a/games-emulation/mupen64/files/mupen64-gtk2-makefile.patch b/games-emulation/mupen64/files/mupen64-gtk2-makefile.patch
index 3e11e0a8f993..f79c4c01ef39 100644
--- a/games-emulation/mupen64/files/mupen64-gtk2-makefile.patch
+++ b/games-emulation/mupen64/files/mupen64-gtk2-makefile.patch
@@ -83,11 +83,11 @@ diff -ru work/hack_azi_rsp_hle/Makefile work.new/hack_azi_rsp_hle/Makefile
+++ hack_azi_rsp_hle/Makefile 2005-03-21 19:28:01.000000000 +0100
@@ -1,7 +1,7 @@
CC = gcc
--CFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
-+CFLAGS = -DUSE_GTK `pkg-config gtk+-2.0 --cflags` -fPIC
+-CFLAGS = -fPIC -DUSE_GTK `gtk-config --cflags`
++CFLAGS = -fPIC -DUSE_GTK `pkg-config gtk+-2.0 --cflags`
CXX = g++
--CXXFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
-+CXXFLAGS = -DUSE_GTK `pkg-config gtk+-2.0 --cflags` -fPIC
+-CXXFLAGS = -fPIC -DUSE_GTK `gtk-config --cflags`
++CXXFLAGS = -fPIC -DUSE_GTK `pkg-config gtk+-2.0 --cflags`
LD = g++
LDFLAGS =
@@ -117,8 +117,8 @@ diff -ru work/mupen64_sound/Makefile work.new/mupen64_sound/Makefile
+++ mupen64_sound/Makefile 2005-03-21 19:28:58.000000000 +0100
@@ -1,7 +1,7 @@
CC = gcc
--CFLAGS = `gtk-config --cflags` -DUSE_GTK
-+CFLAGS = `pkg-config gtk+-2.0 --cflags` -DUSE_GTK
+-CFLAGS = -fPIC `gtk-config --cflags` -DUSE_GTK
++CFLAGS = -fPIC `pkg-config gtk+-2.0 --cflags` -DUSE_GTK
LD = gcc
-LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
+LDFLAGS = -shared -Wl,-Bsymbolic `pkg-config gtk+-2.0 --libs` -lpthread
diff --git a/games-emulation/mupen64/files/mupen64-makefiles.patch b/games-emulation/mupen64/files/mupen64-makefiles.patch
index a2a4e7f8f8f7..5da004d2e85e 100644
--- a/games-emulation/mupen64/files/mupen64-makefiles.patch
+++ b/games-emulation/mupen64/files/mupen64-makefiles.patch
@@ -27,7 +27,7 @@
-#CC =gcc -O3 -I/usr/X11R6/include -fPIC -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=pentium -pipe
-#CC =gcc -O3 -mpentium -Wall -g -pg
-CC =gcc -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall -DUSE_GTK `gtk-config --cflags` -I/usr/X11R6/include -pipe
-+CC =gcc
++CC =gcc -fPIC
OBJ =main.o
@@ -38,10 +38,10 @@
-CFLAGS = -DUSE_GTK `gtk-config --cflags` -O3 -mcpu=athlon \
- -ffast-math -funroll-loops -fomit-frame-pointer
-#CFLAGS = -DUSE_GTK `gtk-config --cflags` -g -fPIC
-+CFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
++CFLAGS = -fPIC -DUSE_GTK `gtk-config --cflags`
CXX = g++
-CXXFLAGS = $(CFLAGS)
-+CXXFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
++CXXFLAGS = -fPIC -DUSE_GTK `gtk-config --cflags`
LD = g++
LDFLAGS =
@@ -50,7 +50,7 @@
@@ -1,5 +1,5 @@
CC = gcc
-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
-+CFLAGS = `gtk-config --cflags` -DUSE_GTK
++CFLAGS = -fPIC `gtk-config --cflags` -DUSE_GTK
LD = gcc
LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread