summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 20:35:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 20:35:06 +0000
commitcc012dceba11e7d7b47071952cb9ad66ee59b7c6 (patch)
tree8f6bca5b46174492c4b75d74e78a12e1238dccfd /games-emulation/mednafen
parentmacos prefix support added, contributed by François Bissey (diff)
downloadgentoo-2-cc012dceba11e7d7b47071952cb9ad66ee59b7c6.tar.gz
gentoo-2-cc012dceba11e7d7b47071952cb9ad66ee59b7c6.tar.bz2
gentoo-2-cc012dceba11e7d7b47071952cb9ad66ee59b7c6.zip
old
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-emulation/mednafen')
-rw-r--r--games-emulation/mednafen/files/mednafen-0.8.12-gcc45.patch28
-rw-r--r--games-emulation/mednafen/mednafen-0.8.12.ebuild61
2 files changed, 0 insertions, 89 deletions
diff --git a/games-emulation/mednafen/files/mednafen-0.8.12-gcc45.patch b/games-emulation/mednafen/files/mednafen-0.8.12-gcc45.patch
deleted file mode 100644
index eb513f77885e..000000000000
--- a/games-emulation/mednafen/files/mednafen-0.8.12-gcc45.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/pce/adpcm.cpp.old 2010-05-24 11:12:19.000000000 +0200
-+++ src/pce/adpcm.cpp 2010-05-24 11:12:40.000000000 +0200
-@@ -244,12 +244,12 @@
- if(f >= 14)
- {
- int rolloff = (int)((((double)32087.5 / (16 - f)) / 2) * 0.70);
-- ADPCMSynth.treble_eq( blip_eq_t::blip_eq_t(-1000, rolloff, FSettings.SndRate));
-+ ADPCMSynth.treble_eq( blip_eq_t(-1000, rolloff, FSettings.SndRate));
- }
- else
- {
- int rolloff = (int)((((double)32087.5 / (16 - f)) / 2) * 0.80);
-- ADPCMSynth.treble_eq( blip_eq_t::blip_eq_t(-1000, rolloff, FSettings.SndRate));
-+ ADPCMSynth.treble_eq( blip_eq_t(-1000, rolloff, FSettings.SndRate));
- }
- }
- }
---- src/pcfx/soundbox.cpp.old 2010-05-24 11:15:20.000000000 +0200
-+++ src/pcfx/soundbox.cpp 2010-05-24 11:15:36.000000000 +0200
-@@ -416,7 +416,7 @@
- int rolloff = (int)((double)0.90 * 21477272 * 2 / 1365 / (1 << SampleFreq) ) / 2;
- for(int ch = 0; ch < 2; ch++)
- for(int lr = 0; lr < 2; lr++)
-- ADPCMSynth[ch][lr].treble_eq(blip_eq_t::blip_eq_t(-1000, rolloff, FSettings.SndRate));
-+ ADPCMSynth[ch][lr].treble_eq(blip_eq_t(-1000, rolloff, FSettings.SndRate));
- LSampleFreq = SampleFreq;
- }
- }
diff --git a/games-emulation/mednafen/mednafen-0.8.12.ebuild b/games-emulation/mednafen/mednafen-0.8.12.ebuild
deleted file mode 100644
index 74f57c380fe1..000000000000
--- a/games-emulation/mednafen/mednafen-0.8.12.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.8.12.ebuild,v 1.4 2010/05/24 09:40:42 tupone Exp $
-
-EAPI=2
-inherit autotools eutils games
-
-DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator"
-HOMEPAGE="http://mednafen.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/mednafen-${PV/12/C}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="alsa cjk debug jack nls"
-
-RDEPEND="virtual/opengl
- media-libs/libsndfile
- dev-libs/libcdio
- media-libs/libsdl
- media-libs/sdl-net
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- sed -i \
- -e 's:$(datadir)/locale:/usr/share/locale:' \
- -e 's:$(localedir):/usr/share/locale:' \
- $(find . -name 'Makefile.*') \
- || die 'sed failed'
- sed -i \
- -e '/-fomit-frame-pointer/d' \
- -e '/-ffast-math/d' \
- configure.ac \
- || die "sed failed"
- epatch "${FILESDIR}"/${P}-gcc45.patch
- eautoreconf
-}
-
-src_configure() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable alsa) \
- $(use_enable cjk cjk-fonts) \
- $(use_enable debug debugger) \
- $(use_enable jack) \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc Documentation/cheats.txt AUTHORS ChangeLog TODO
- dohtml Documentation/*
- prepgamesdirs
-}