summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-07-24 17:30:46 +0000
committerHanno Böck <hanno@gentoo.org>2009-07-24 17:30:46 +0000
commit11287713e2f72f8b7c666a4f46cf7b70482a1051 (patch)
tree2e11c53ce03cb56072959a2eb1f2b699db8ac0db /games-emulation/desmume
parentFix building with GCC 4.4 wrt #269258, thanks to Martin Väth. (diff)
downloadgentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.tar.gz
gentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.tar.bz2
gentoo-2-11287713e2f72f8b7c666a4f46cf7b70482a1051.zip
desmume gcc44 patch
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/desmume')
-rw-r--r--games-emulation/desmume/ChangeLog6
-rw-r--r--games-emulation/desmume/desmume-0.8.ebuild39
-rw-r--r--games-emulation/desmume/desmume-0.9.4.ebuild8
-rw-r--r--games-emulation/desmume/desmume-0.9.ebuild33
-rw-r--r--games-emulation/desmume/files/desmume-0.9.4-gcc44.patch11
-rw-r--r--games-emulation/desmume/files/desmume-desktop.patch32
6 files changed, 22 insertions, 107 deletions
diff --git a/games-emulation/desmume/ChangeLog b/games-emulation/desmume/ChangeLog
index 91a9a957d1f5..2f10e5289ebf 100644
--- a/games-emulation/desmume/ChangeLog
+++ b/games-emulation/desmume/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/desmume
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/ChangeLog,v 1.13 2009/07/10 22:33:43 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/ChangeLog,v 1.14 2009/07/24 17:30:46 hanno Exp $
+
+ 24 Jul 2009; Hanno Boeck <hanno@gentoo.org> desmume-0.9.4.ebuild,
+ +files/desmume-0.9.4-gcc44.patch:
+ Patch for gcc 4.4.
*desmume-0.9.4 (10 Jul 2009)
diff --git a/games-emulation/desmume/desmume-0.8.ebuild b/games-emulation/desmume/desmume-0.8.ebuild
deleted file mode 100644
index e5897e6a84cd..000000000000
--- a/games-emulation/desmume/desmume-0.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.8.ebuild,v 1.4 2009/01/10 22:53:48 hanno Exp $
-
-inherit games eutils
-
-DESCRIPTION="Emulator for Nintendo DS."
-HOMEPAGE="http://desmume.sourceforge.net/"
-SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-2.8.0
- gnome-base/libglade
- x11-libs/gtkglext
- virtual/opengl
- sys-libs/zlib
- dev-libs/zziplib
- media-libs/libsdl"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-desktop.patch"
-}
-
-src_compile() {
- egamesconf --datadir=/usr/share || die "egamesconf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake failed"
- dodoc AUTHORS ChangeLog README README.LIN
- prepgamesdirs
-}
diff --git a/games-emulation/desmume/desmume-0.9.4.ebuild b/games-emulation/desmume/desmume-0.9.4.ebuild
index afcf66e0f99d..49de72d7d184 100644
--- a/games-emulation/desmume/desmume-0.9.4.ebuild
+++ b/games-emulation/desmume/desmume-0.9.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.4.ebuild,v 1.1 2009/07/10 22:33:43 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.4.ebuild,v 1.2 2009/07/24 17:30:46 hanno Exp $
EAPI="2"
-inherit games
+inherit games eutils
DESCRIPTION="Emulator for Nintendo DS."
HOMEPAGE="http://desmume.org/"
@@ -26,6 +26,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc44.patch"
+}
+
src_compile() {
egamesconf --datadir=/usr/share || die "egamesconf failed"
emake || die "emake failed"
diff --git a/games-emulation/desmume/desmume-0.9.ebuild b/games-emulation/desmume/desmume-0.9.ebuild
deleted file mode 100644
index cd2c17c8568c..000000000000
--- a/games-emulation/desmume/desmume-0.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.ebuild,v 1.1 2009/01/10 22:53:48 hanno Exp $
-
-inherit games
-
-DESCRIPTION="Emulator for Nintendo DS."
-HOMEPAGE="http://desmume.org/"
-SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-2.8.0
- gnome-base/libglade
- x11-libs/gtkglext
- virtual/opengl
- sys-libs/zlib
- dev-libs/zziplib
- media-libs/libsdl"
-
-src_compile() {
- egamesconf --datadir=/usr/share || die "egamesconf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake failed"
- dodoc AUTHORS ChangeLog README README.LIN
- prepgamesdirs
-}
diff --git a/games-emulation/desmume/files/desmume-0.9.4-gcc44.patch b/games-emulation/desmume/files/desmume-0.9.4-gcc44.patch
new file mode 100644
index 000000000000..d95a16c8aae1
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.4-gcc44.patch
@@ -0,0 +1,11 @@
+--- desmume-0.9.4/src/texcache.h 2009-07-08 11:11:01.000000000 +0300
++++ desmume-0.9.4-gcc44/src/texcache.h 2009-07-24 20:21:16.000000000 +0300
+@@ -43,7 +43,7 @@
+
+ void TexCache_Reset();
+
+-template<TexCache_TexFormat format>
++template<TexCache_TexFormat>
+ void TexCache_SetTexture(u32 format, u32 texpal);
+
+ void TexCache_Invalidate();
diff --git a/games-emulation/desmume/files/desmume-desktop.patch b/games-emulation/desmume/files/desmume-desktop.patch
deleted file mode 100644
index e4430880b9ed..000000000000
--- a/games-emulation/desmume/files/desmume-desktop.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/gtk/desmume.desktop.in~ 2008-09-12 13:43:42.000000000 +0200
-+++ src/gtk/desmume.desktop.in 2008-09-12 13:43:42.000000000 +0200
-@@ -1,10 +1,9 @@
- [Desktop Entry]
--Encoding=UTF-8
--Version=@VERSION@
-+Version=1.0
- Type=Application
- Name=DeSmuME (Gtk)
- Comment=Nintento DS emulator
- TryExec=desmume
- Exec=desmume
--Icon=DeSmuME.xpm
--Categories=GNOME;GTK;Game;Emulator
-+Icon=DeSmuME
-+Categories=GNOME;GTK;Game;Emulator;
---- src/gtk-glade/desmume-glade.desktop.in~ 2008-09-12 13:44:29.000000000 +0200
-+++ src/gtk-glade/desmume-glade.desktop.in 2008-09-12 13:44:29.000000000 +0200
-@@ -1,10 +1,9 @@
- [Desktop Entry]
--Encoding=UTF-8
--Version=@VERSION@
-+Version=1.0
- Type=Application
- Name=DeSmuME (Gtk-Glade)
- Comment=Nintento DS emulator
- TryExec=desmume-glade
- Exec=desmume-glade
--Icon=DeSmuME.xpm
--Categories=GNOME;GTK;Game;Emulator
-+Icon=DeSmuME
-+Categories=GNOME;GTK;Game;Emulator;