summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 08:29:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 08:29:51 +0000
commit410774e9fc2733428ca1dc0cf20b802783a9cd95 (patch)
tree820318c665332fff09249d3a7ce11b52a4098802 /games-emulation/darcnes
parentclean old ebuild (diff)
downloadgentoo-2-410774e9fc2733428ca1dc0cf20b802783a9cd95.tar.gz
gentoo-2-410774e9fc2733428ca1dc0cf20b802783a9cd95.tar.bz2
gentoo-2-410774e9fc2733428ca1dc0cf20b802783a9cd95.zip
applied joypad emulation patch from Alastair Bridgewater (bug #75391); tid
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/darcnes')
-rw-r--r--games-emulation/darcnes/ChangeLog5
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild37
2 files changed, 23 insertions, 19 deletions
diff --git a/games-emulation/darcnes/ChangeLog b/games-emulation/darcnes/ChangeLog
index 53cc8dadbdf4..8656ebc4e7f1 100644
--- a/games-emulation/darcnes/ChangeLog
+++ b/games-emulation/darcnes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/darcnes
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.10 2005/03/13 08:18:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.11 2005/03/13 08:29:51 mr_bones_ Exp $
+
+ 13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> darcnes-0401-r2.ebuild:
+ applied joypad emulation patch from Alastair Bridgewater (bug #75391); tidy
13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
-darcnes-0401-r1.ebuild:
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index d6babce42c82..7c3eb8053abd 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.8 2005/03/13 08:18:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.9 2005/03/13 08:29:51 mr_bones_ Exp $
inherit eutils games
@@ -10,7 +10,7 @@ SRC_URI="http://www.dridus.com/~nyef/darcnes/download/dn9b${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 -ppc"
+KEYWORDS="-ppc x86"
IUSE="gtk svga X"
DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
@@ -20,35 +20,36 @@ DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
virtual/x11
=x11-libs/gtk+-1.2* )"
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- build_X=true
- use svga && build_X=false
- use gtk && build_X=false
- use X && build_X=true
- games_pkg_setup
-}
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}-gcc34.patch
+ epatch "${FILESDIR}/${P}-gcc34.patch"
+ # bug #75391
+ sed -i \
+ -e "s/buttons\[0\]/buttons\[\]/" ui.h \
+ || die "sed failed"
}
src_compile() {
+ build_X=true
+ use svga && build_X=false
+ use gtk && build_X=false
+ use X && build_X=true
+
if use svga ; then
- emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_svgalib failed"
+ emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_svgalib failed"
fi
if use gtk ; then
- emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_GTK failed"
+ emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_GTK failed"
fi
if $build_X ; then
- emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_X failed"
+ emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_X failed"
fi
}