summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-13 00:06:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-13 00:06:59 +0000
commite804b0346f6d5872988bb6bfa24acf1b04e059cc (patch)
treed6d5f2f5d2879d7d537eb71357d3e208a5e0caf4 /games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild
parentinitial commit; ebuild submitted by Chris Aniszczyk via bug 37943 (diff)
downloadgentoo-2-e804b0346f6d5872988bb6bfa24acf1b04e059cc.tar.gz
gentoo-2-e804b0346f6d5872988bb6bfa24acf1b04e059cc.tar.bz2
gentoo-2-e804b0346f6d5872988bb6bfa24acf1b04e059cc.zip
initial commit; ebuild submitted by Chris Aniszczyk via bug 37943
Diffstat (limited to 'games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild')
-rw-r--r--games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild b/games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild
new file mode 100644
index 000000000000..bad88274ce1d
--- /dev/null
+++ b/games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/boycott-advance-sdl/boycott-advance-sdl-0.2.8.ebuild,v 1.1 2004/01/13 00:06:44 mr_bones_ Exp $
+
+inherit games
+
+MY_RLS="R1"
+DESCRIPTION="A Gameboy Advance (GBA) emulator for Linux"
+HOMEPAGE="http://sdlemu.ngemu.com/basdl.php"
+SRC_URI="http://sdlemu.ngemu.com/releases/BoyCottAdvance-SDL-${PV}${MY_RLS}.i386.linux.tar.gz"
+
+KEYWORDS="-* x86"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/x11
+ virtual/opengl
+ >=media-libs/libsdl-1.2
+ sys-libs/zlib"
+
+S="${WORKDIR}/boyca-sdl"
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ exeinto "${dir}"
+ doexe boyca || die "doexe failed"
+ insinto "${dir}/roms"
+ doins PongFighter/* || die "doins failed (roms)"
+ insinto "${dir}"
+ doins boyca.cfg || die "doins failed (cfg)"
+ dodoc docs/* || die "dodoc failed"
+
+ games_make_wrapper boyca ./boyca "${dir}"
+
+ prepgamesdirs
+}