summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-08 13:50:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-08 13:50:09 +0000
commitf060a5ce44d252aa14c8be0d913ff6e26e1e6c9b (patch)
tree673ef325cd2e92434f7f8173e011612d0aa0e2cb /games-board
parentInitial addition. (diff)
downloadgentoo-2-f060a5ce44d252aa14c8be0d913ff6e26e1e6c9b.tar.gz
gentoo-2-f060a5ce44d252aa14c8be0d913ff6e26e1e6c9b.tar.bz2
gentoo-2-f060a5ce44d252aa14c8be0d913ff6e26e1e6c9b.zip
Fix build with qt-4.7 Bug #338502
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/qgo/ChangeLog6
-rw-r--r--games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch74
-rw-r--r--games-board/qgo/qgo-1.5.4_p20100322.ebuild8
3 files changed, 84 insertions, 4 deletions
diff --git a/games-board/qgo/ChangeLog b/games-board/qgo/ChangeLog
index 9fd6c9ff0b40..cbecc65555a5 100644
--- a/games-board/qgo/ChangeLog
+++ b/games-board/qgo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/qgo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.42 2010/06/01 08:13:45 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.43 2010/11/08 13:50:09 tupone Exp $
+
+ 08 Nov 2010; Tupone Alfredo <tupone@gentoo.org>
+ qgo-1.5.4_p20100322.ebuild, +files/qgo-1.5.4_p20100322-qt47.patch:
+ Fix build with qt-4.7 Bug #338502 by flameeyes@gentoo.org
01 Jun 2010; Tupone Alfredo <tupone@gentoo.org>
qgo-1.5.4_p20100322.ebuild, +files/qgo-1.5.4_p20100322-gcc45.patch:
diff --git a/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch b/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch
new file mode 100644
index 000000000000..bf8bfee3cce2
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch
@@ -0,0 +1,74 @@
+--- src/network/playergamelistings.h.old 2010-11-08 13:49:25.000000000 +0100
++++ src/network/playergamelistings.h 2010-11-08 13:52:24.000000000 +0100
+@@ -66,21 +66,21 @@
+ bool hidden;
+ PlayerListing() : id(0),
+ online(0),
+- name(0),
+- notnickname(0),
+- info(0),
+- idletime(0),
++ name(QString::null),
++ notnickname(QString::null),
++ info(QString::null),
++ idletime(QString::null),
+ seconds_idle(0),
+- rank(0),
++ rank(QString::null),
+ rank_score(0),
+- country(0),
++ country(QString::null),
+ wins(0),
+ losses(0),
+ rated_games(0),
+ observing(0),
+ playing(0),
+- extInfo(0),
+- email_address(0),
++ extInfo(QString::null),
++ email_address(QString::null),
+ nmatch(0),
+ nmatch_handicapMin(0),
+ specialbyte(0),
+@@ -189,7 +189,7 @@
+ _white_rank_score(0),
+ _black_rank_score(0),
+ observers(0),
+- result(0),
++ result(QString::null),
+ flags(IN_PROGRESS),
+ rated(0),
+ owner_id(0),
+--- src/board/board.h.old 2010-11-08 13:57:26.000000000 +0100
++++ src/board/board.h 2010-11-08 13:58:17.000000000 +0100
+@@ -50,7 +50,7 @@
+
+ void removeGhosts();
+ void setVarGhost(StoneColor c, int x, int y);
+- void setMark(int x, int y, MarkType t, bool update=true, QString txt=0, bool overlay=true);
++ void setMark(int x, int y, MarkType t, bool update=true, QString txt=QString::null, bool overlay=true);
+ Mark* hasMark(int x, int y);
+ void removeMark(int x, int y, bool update = false);
+ void removeDeadMarks();
+--- src/board/boardwindow.h.old 2010-11-08 14:21:19.000000000 +0100
++++ src/board/boardwindow.h 2010-11-08 14:21:39.000000000 +0100
+@@ -45,7 +45,7 @@
+ ~BoardWindow();
+
+ void init();
+- bool loadSGF(const QString fileName, const QString SGFLoaded=0);
++ bool loadSGF(const QString fileName, const QString SGFLoaded=QString::null);
+ bool doSave(QString fileName, bool force);
+ QString getCandidateFileName();
+
+--- src/sgf/sgfparser.h.old 2010-11-08 14:29:05.000000000 +0100
++++ src/sgf/sgfparser.h 2010-11-08 14:29:27.000000000 +0100
+@@ -51,7 +51,7 @@
+ */
+ protected:
+ int minPos(int n1, int n2, int n3);
+- bool corruptSgf(int where=0, QString reason=NULL);
++ bool corruptSgf(int where=0, QString reason=QString::null);
+
+ bool parseProperty(const QString &toParse, const QString &prop, QString &result);
+
diff --git a/games-board/qgo/qgo-1.5.4_p20100322.ebuild b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
index 6a8bf18f4edc..4b41970f0915 100644
--- a/games-board/qgo/qgo-1.5.4_p20100322.ebuild
+++ b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-1.5.4_p20100322.ebuild,v 1.6 2010/09/03 17:22:09 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-1.5.4_p20100322.ebuild,v 1.7 2010/11/08 13:50:09 tupone Exp $
EAPI=2
inherit eutils qt4-r2 games
@@ -14,10 +14,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="media-libs/alsa-lib
+RDEPEND="media-libs/alsa-lib
x11-libs/qt-core:4
x11-libs/qt-gui:4
x11-libs/qt-test:4"
+DEPEND="${RDEPEND}"
src_prepare() {
sed -i \
@@ -30,7 +31,8 @@ src_prepare() {
-e "/TRANSLATIONS_PATH_PREFIX/s:/usr/share:${GAMES_DATADIR}:" \
src/defines.h || die
- epatch "${FILESDIR}"/${P}-gcc45.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-qt47.patch
}
src_configure() {