summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 20:01:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 20:01:31 +0000
commiteeaf22ff73cb73aa56e8d12299d255e3ceea2021 (patch)
treec9b7e5e113cfd25570154e5e8435e8fab2a01ac1 /games-board
parentold (diff)
downloadgentoo-2-eeaf22ff73cb73aa56e8d12299d255e3ceea2021.tar.gz
gentoo-2-eeaf22ff73cb73aa56e8d12299d255e3ceea2021.tar.bz2
gentoo-2-eeaf22ff73cb73aa56e8d12299d255e3ceea2021.zip
Fix deprecation warning. Use distutils_pkg_postinst() and distutils_pkg_postrm().
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysolfc/ChangeLog8
-rw-r--r--games-board/pysolfc/pysolfc-2.0.ebuild14
2 files changed, 12 insertions, 10 deletions
diff --git a/games-board/pysolfc/ChangeLog b/games-board/pysolfc/ChangeLog
index bf078d85b9e0..153c8bc18e3c 100644
--- a/games-board/pysolfc/ChangeLog
+++ b/games-board/pysolfc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pysolfc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.3 2010/05/31 18:12:51 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.4 2011/04/06 20:01:31 arfrever Exp $
+
+ 06 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pysolfc-2.0.ebuild:
+ Fix deprecation warning. Use distutils_pkg_postinst() and distutils_pkg_postrm().
31 May 2010; Markus Meier <maekke@gentoo.org> pysolfc-2.0.ebuild:
amd64/x86 stable, bug #315295
diff --git a/games-board/pysolfc/pysolfc-2.0.ebuild b/games-board/pysolfc/pysolfc-2.0.ebuild
index e25801a87633..f096772f4640 100644
--- a/games-board/pysolfc/pysolfc-2.0.ebuild
+++ b/games-board/pysolfc/pysolfc-2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0.ebuild,v 1.6 2010/05/31 18:12:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0.ebuild,v 1.7 2011/04/06 20:01:31 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_USE_WITH="tk"
PYTHON_DEPEND="2:2.6"
@@ -28,6 +28,8 @@ RDEPEND="sound? ( dev-python/pygame )
!minimal? ( dev-python/imaging[tk]
dev-tcltk/tktable )"
+PYTHON_MODNAME="pysollib"
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
@@ -73,9 +75,5 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- python_mod_optimize $(python_get_sitedir)/pysollib
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/pysollib
+ distutils_pkg_postinst
}