summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-17 13:42:20 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-17 13:42:20 +0000
commitc9674691d32e3024c2cbf38aa14576a9c8a9cd90 (patch)
treefc14245e13bb709fbaa50a07d804ae162d18bf38 /games-board
parentUse full atoms for has_version. (diff)
downloadgentoo-2-c9674691d32e3024c2cbf38aa14576a9c8a9cd90.tar.gz
gentoo-2-c9674691d32e3024c2cbf38aa14576a9c8a9cd90.tar.bz2
gentoo-2-c9674691d32e3024c2cbf38aa14576a9c8a9cd90.zip
Version bump
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/qgo/ChangeLog8
-rw-r--r--games-board/qgo/files/digest-qgo-1.5.43
-rw-r--r--games-board/qgo/files/qgo-1.5.4-parallel.patch22
-rw-r--r--games-board/qgo/qgo-1.5.4.ebuild34
4 files changed, 66 insertions, 1 deletions
diff --git a/games-board/qgo/ChangeLog b/games-board/qgo/ChangeLog
index 7f0dcf403d78..0de2c88ce727 100644
--- a/games-board/qgo/ChangeLog
+++ b/games-board/qgo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/qgo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.26 2007/06/02 10:00:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.27 2007/06/17 13:42:20 nyhm Exp $
+
+*qgo-1.5.4 (17 Jun 2007)
+
+ 17 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/qgo-1.5.4-parallel.patch, +qgo-1.5.4.ebuild:
+ Version bump
02 Jun 2007; Tupone Alfredo <tupone@gentoo.org>
+files/qgo-1.5.3-parallel.patch, qgo-1.5.3.ebuild:
diff --git a/games-board/qgo/files/digest-qgo-1.5.4 b/games-board/qgo/files/digest-qgo-1.5.4
new file mode 100644
index 000000000000..0987cca47918
--- /dev/null
+++ b/games-board/qgo/files/digest-qgo-1.5.4
@@ -0,0 +1,3 @@
+MD5 a91e903194d676ee9970300adcef70b1 qgo-1.5.4.tar.gz 2427901
+RMD160 82e4220c268124774b109d078fa82c65520d4394 qgo-1.5.4.tar.gz 2427901
+SHA256 1c5dd7171e4da1339b0d95c3f1cfed8a592e6e4b8dc0bf446a5d3fc02e62d014 qgo-1.5.4.tar.gz 2427901
diff --git a/games-board/qgo/files/qgo-1.5.4-parallel.patch b/games-board/qgo/files/qgo-1.5.4-parallel.patch
new file mode 100644
index 000000000000..ed94161ea01a
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4-parallel.patch
@@ -0,0 +1,22 @@
+--- src/sounds/Makefile.in.bad 2007-06-02 11:24:44.000000000 +0200
++++ src/sounds/Makefile.in 2007-06-02 11:25:08.000000000 +0200
+@@ -373,7 +353,7 @@
+
+ info-am:
+
+-install-data-am: install-SoundsDATA install-data-local
++install-data-am: install-SoundsDATA
+
+ install-exec-am:
+
+--- src/translations/Makefile.in.bad 2007-06-02 11:24:48.000000000 +0200
++++ src/translations/Makefile.in 2007-06-02 11:25:08.000000000 +0200
+@@ -374,7 +353,7 @@
+
+ info-am:
+
+-install-data-am: install-TranslationsDATA install-data-local
++install-data-am: install-TranslationsDATA
+
+ install-exec-am:
+
diff --git a/games-board/qgo/qgo-1.5.4.ebuild b/games-board/qgo/qgo-1.5.4.ebuild
new file mode 100644
index 000000000000..fbe5eb90030d
--- /dev/null
+++ b/games-board/qgo/qgo-1.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-1.5.4.ebuild,v 1.1 2007/06/17 13:42:20 nyhm Exp $
+
+inherit eutils autotools qt3 games
+
+DESCRIPTION="A Qt Go client and SGF editor"
+HOMEPAGE="http://qgo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qgo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-parallel.patch
+ sed -i 's:$(datadir):/usr/share:' \
+ templates/Makefile.in \
+ || die "sed Makefile.in failed"
+ sed -i "s:/usr/share:${GAMES_DATADIR}:" \
+ templates/*.desktop \
+ || die "sed .desktop failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}