summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-07 11:54:20 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-07 11:54:20 +0000
commit2bda9d7a3f35f5e43a81099b232190209bf46296 (patch)
tree066687071ab8fa337a739f4840ef9096be807e6d /games-board
parentp.use.mask armv7 on games-board/stockfish (diff)
downloadgentoo-2-2bda9d7a3f35f5e43a81099b232190209bf46296.tar.gz
gentoo-2-2bda9d7a3f35f5e43a81099b232190209bf46296.tar.bz2
gentoo-2-2bda9d7a3f35f5e43a81099b232190209bf46296.zip
Ebuild improvements
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/stockfish/ChangeLog8
-rw-r--r--games-board/stockfish/metadata.xml6
-rw-r--r--games-board/stockfish/stockfish-6-r1.ebuild59
-rw-r--r--games-board/stockfish/stockfish-6.ebuild40
4 files changed, 72 insertions, 41 deletions
diff --git a/games-board/stockfish/ChangeLog b/games-board/stockfish/ChangeLog
index 304ceb3ed0b7..42f913a9660d 100644
--- a/games-board/stockfish/ChangeLog
+++ b/games-board/stockfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/stockfish
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/ChangeLog,v 1.1 2015/02/05 20:09:33 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/ChangeLog,v 1.2 2015/02/07 11:54:20 yngwin Exp $
+
+*stockfish-6-r1 (07 Feb 2015)
+
+ 07 Feb 2015; Ben de Groot <yngwin@gentoo.org> -stockfish-6.ebuild,
+ +stockfish-6-r1.ebuild, metadata.xml:
+ Ebuild improvements
*stockfish-6 (05 Feb 2015)
diff --git a/games-board/stockfish/metadata.xml b/games-board/stockfish/metadata.xml
index f2b4a5d1d932..1f5c48a54c2b 100644
--- a/games-board/stockfish/metadata.xml
+++ b/games-board/stockfish/metadata.xml
@@ -5,4 +5,10 @@
<email>yngwin@gentoo.org</email>
<name>Ben de Groot</name>
</maintainer>
+ <use>
+ <flag name='armv7'>Build for armv7; enables PIE</flag>
+ <flag name='general-32'>Generic unoptimized 32-bits build</flag>
+ <flag name='general-64'>Generic unoptimized 64-bits build</flag>
+ <flag name='optimize'>Enable upstream -O3 optimizations (default enabled)</flag>
+ </use>
</pkgmetadata>
diff --git a/games-board/stockfish/stockfish-6-r1.ebuild b/games-board/stockfish/stockfish-6-r1.ebuild
new file mode 100644
index 000000000000..37b6a857b872
--- /dev/null
+++ b/games-board/stockfish/stockfish-6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/stockfish-6-r1.ebuild,v 1.1 2015/02/07 11:54:20 yngwin Exp $
+
+EAPI=5
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/official-stockfish/Stockfish.git"
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/src
+else
+ SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${P}-src/src
+fi
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="http://stockfishchess.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+ # other architectures
+ use armv7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ emake build ARCH=${my_arch} \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc ../AUTHORS ../Readme.md
+}
diff --git a/games-board/stockfish/stockfish-6.ebuild b/games-board/stockfish/stockfish-6.ebuild
deleted file mode 100644
index 53a35518c7cf..000000000000
--- a/games-board/stockfish/stockfish-6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/stockfish-6.ebuild,v 1.1 2015/02/05 20:09:33 yngwin Exp $
-
-EAPI=5
-inherit toolchain-funcs
-
-DESCRIPTION="The strongest chess engine in the world"
-HOMEPAGE="http://stockfishchess.org/"
-SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse"
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${P}-src/src
-
-src_prepare() {
- sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile
-}
-
-src_compile() {
- local my_arch
- use x86 && my_arch=x86-32-old
- use cpu_flags_x86_sse && my_arch=x86-32
- use amd64 && my_arch=x86-64
- use cpu_flags_x86_popcnt && my_arch=x86-64-modern
- use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
-
- emake build ARCH=${my_arch} CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
- emake PREFIX="${D}/usr" install
- dodoc ../AUTHORS ../Readme.md
-}