summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-11 16:32:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-11 16:32:10 +0000
commitc7fb7843ee1842916e8e31742accd3841ff12371 (patch)
tree0d6a006cb7b9a4296f11de18e9266e3f9c8f6687 /games-board/pychess
parentFix testsuite; missing dev-libs/check dependency and virtualx usage for dummy... (diff)
downloadgentoo-2-c7fb7843ee1842916e8e31742accd3841ff12371.tar.gz
gentoo-2-c7fb7843ee1842916e8e31742accd3841ff12371.tar.bz2
gentoo-2-c7fb7843ee1842916e8e31742accd3841ff12371.zip
migrate to distutils-r1
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/ChangeLog9
-rw-r--r--games-board/pychess/pychess-0.10.1-r1.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/games-board/pychess/ChangeLog b/games-board/pychess/ChangeLog
index 14c28c77abf3..a108d95fae94 100644
--- a/games-board/pychess/ChangeLog
+++ b/games-board/pychess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pychess
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.18 2012/08/07 09:54:44 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.19 2013/01/11 16:32:10 hasufell Exp $
+
+*pychess-0.10.1-r1 (11 Jan 2013)
+
+ 11 Jan 2013; Julian Ospald <hasufell@gentoo.org> +pychess-0.10.1-r1.ebuild:
+ migrate to distutils-r1
07 Aug 2012; Tim Harder <radhermit@gentoo.org> -pychess-0.10.ebuild:
Remove old.
diff --git a/games-board/pychess/pychess-0.10.1-r1.ebuild b/games-board/pychess/pychess-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..671b9c1c1c00
--- /dev/null
+++ b/games-board/pychess/pychess-0.10.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.10.1-r1.ebuild,v 1.1 2013/01/11 16:32:10 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+# inherit base explicitly to avoid overrides on distutils-r1
+inherit base fdo-mime gnome2-utils distutils-r1 games
+
+DESCRIPTION="A chess client for Gnome"
+HOMEPAGE="http://pychess.googlepages.com/home"
+SRC_URI="http://pychess.googlecode.com/files/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+DEPEND="dev-python/librsvg-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ dev-python/pygtk
+ dev-python/pygtksourceview
+ dev-python/pysqlite
+ gstreamer? ( dev-python/gst-python )
+ dev-python/gconf-python
+ x11-themes/gnome-icon-theme"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_/}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+python_install_all() {
+ dodoc AUTHORS README
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+ fdo-mime_desktop_database_update
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}