summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-26 11:12:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-26 11:12:05 +0000
commitb3707c9045e4752d1b8cc0d93995f9920d9a3a9a (patch)
treeb55f05e3022fbb2e34c832ef1ec0440bcf9e5660 /games-board/crafty
parentx86 stable, bug #201306 (diff)
downloadgentoo-2-b3707c9045e4752d1b8cc0d93995f9920d9a3a9a.tar.gz
gentoo-2-b3707c9045e4752d1b8cc0d93995f9920d9a3a9a.tar.bz2
gentoo-2-b3707c9045e4752d1b8cc0d93995f9920d9a3a9a.zip
Adding some documentation
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/crafty-21.6-r1.ebuild89
-rw-r--r--games-board/crafty/files/digest-crafty-21.6-r16
3 files changed, 101 insertions, 1 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index b86a1b08dcd2..6f4b862260b0 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.23 2007/12/09 10:25:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.24 2007/12/26 11:12:04 tupone Exp $
+
+*crafty-21.6-r1 (26 Dec 2007)
+
+ 26 Dec 2007; Tupone Alfredo <tupone@gentoo.org> +crafty-21.6-r1.ebuild:
+ Adding some documentation.
09 Dec 2007; <atupone@gentoo.org> crafty-21.6.ebuild:
Fix problem on x86_64 platform.
diff --git a/games-board/crafty/crafty-21.6-r1.ebuild b/games-board/crafty/crafty-21.6-r1.ebuild
new file mode 100644
index 000000000000..887b8fd3131b
--- /dev/null
+++ b/games-board/crafty/crafty-21.6-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6-r1.ebuild,v 1.1 2007/12/26 11:12:04 tupone Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip
+ ftp://ftp.cis.uab.edu/pub/hyatt/documentation/${PN}.doc.ascii"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="icc no-opts"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' \
+ -e 's:CXFLAGS:CXXFLAGS:g' \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
+ || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++"
+ elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fomit-frame-pointer
+ makeopts="${makeopts} CC=gcc CXX=g++"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ dodoc "${DISTDIR}"/crafty.doc.ascii
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog
+ elog "Note: No books or tablebases have been installed. If you want them, just"
+ elog " download them from ${HOMEPAGE}."
+ elog " You will find documentation there too. In most cases you take now "
+ elog " your xboard compatible application, (xboard, eboard, knights) and "
+ elog " just play chess against computer opponent. Have fun."
+ elog
+}
diff --git a/games-board/crafty/files/digest-crafty-21.6-r1 b/games-board/crafty/files/digest-crafty-21.6-r1
new file mode 100644
index 000000000000..8366cddce0e0
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-21.6-r1
@@ -0,0 +1,6 @@
+MD5 3ba77a663e85e180c7d95fda1722449f crafty-21.6.zip 423100
+RMD160 d8fd129967638cbe614e7d3a90e9a4f53db93024 crafty-21.6.zip 423100
+SHA256 be5ec37938f7b741e5f3bded193fb6e30e0cb69f910202b7cc01f01846b42b56 crafty-21.6.zip 423100
+MD5 5fd73027a1de1674763562e1987197ba crafty.doc.ascii 79678
+RMD160 f0c8304efcaa93a14a37da96d22bb25cda8d1bf5 crafty.doc.ascii 79678
+SHA256 be291c0f4c7e7d64404ec58b9e92c2455c4342d3c96c721ba21a80fce8332e83 crafty.doc.ascii 79678