summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-28 06:00:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-28 06:00:36 +0000
commitf598257d078d6bf65e1161e4a9c5b4fea752468e (patch)
treee5b0220a304a9f7121041c631d36736a1d29f042 /games-arcade
parentIUSE fix; use sed -i; error check (Manifest recommit) (diff)
downloadgentoo-2-f598257d078d6bf65e1161e4a9c5b4fea752468e.tar.gz
gentoo-2-f598257d078d6bf65e1161e4a9c5b4fea752468e.tar.bz2
gentoo-2-f598257d078d6bf65e1161e4a9c5b4fea752468e.zip
fix IUSE; error check; tidy
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/koules/ChangeLog5
-rw-r--r--games-arcade/koules/koules-1.4-r1.ebuild57
2 files changed, 34 insertions, 28 deletions
diff --git a/games-arcade/koules/ChangeLog b/games-arcade/koules/ChangeLog
index 388237d7e2f3..c3015c973b4a 100644
--- a/games-arcade/koules/ChangeLog
+++ b/games-arcade/koules/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/koules
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/ChangeLog,v 1.3 2004/03/27 09:58:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/ChangeLog,v 1.4 2004/03/28 06:00:36 mr_bones_ Exp $
+
+ 27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> koules-1.4-r1.ebuild:
+ fix IUSE; error check; tidy
27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> koules-1.4-r1.ebuild:
use || in DEPEND and RDEPEND to say what we really mean
diff --git a/games-arcade/koules/koules-1.4-r1.ebuild b/games-arcade/koules/koules-1.4-r1.ebuild
index b2d7b9e32960..7a8a8315707a 100644
--- a/games-arcade/koules/koules-1.4-r1.ebuild
+++ b/games-arcade/koules/koules-1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r1.ebuild,v 1.4 2004/03/27 09:58:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r1.ebuild,v 1.5 2004/03/28 06:00:36 mr_bones_ Exp $
inherit eutils games
@@ -11,22 +11,19 @@ SRC_URI="http://www.ucw.cz/~hubicka/koules/packages/koules${PV}-src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE="X svga joystick"
+IUSE="svga joystick tcltk"
DEPEND=">=sys-apps/sed-4
|| (
svga? ( media-libs/svgalib )
- X? ( virtual/x11 )
virtual/x11 )"
RDEPEND="virtual/glibc
|| (
svga? ( media-libs/svgalib )
- X? ( virtual/x11 )
virtual/x11 )
|| (
tcltk? ( dev-lang/tk dev-lang/tcl )
- dev-util/dialog
- )"
+ dev-util/dialog )"
S="${WORKDIR}/${PN}${PV}"
@@ -36,25 +33,28 @@ src_unpack() {
epatch "${FILESDIR}/${PV}-gcc3.patch"
sed -i \
-e "/^KOULESDIR/s:=.*:=${GAMES_BINDIR}:" \
- -e "/^SOUNDDIR/s:=.*:=${GAMES_DATADIR}/${PN}:" \
- Iconfig || die
+ -e "/^SOUNDDIR/s:=.*:=${GAMES_DATADIR}/${PN}:" Iconfig \
+ || die "sed Iconfig failed"
sed -i \
-e 's:-c -o $*.o:-c:' \
-e 's:-S -o $*.s:-S:' \
-e 's:$(ARCH)::' \
-e "s:-fomit-frame-pointer -O3 -ffast-math:${CFLAGS}:" \
- Makefile.svgalib
- #[ ${ARCH} == "x86" ] && echo '#define I386ASSEMBLY' >> Iconfig
- [ `use joystick` ] && echo '#define JOYSTICK' >> Iconfig
- sed -i "s:/usr/local/bin:${GAMES_BINDIR}:" koules
- if [ `use tcltk` ] ; then
+ Makefile.svgalib || die "sed Makefile.svgalib failed"
+ use joystick && echo '#define JOYSTICK' >> Iconfig
+ sed -i \
+ -e "s:/usr/local/bin:${GAMES_BINDIR}:" koules \
+ || die "sed koules failed"
+ if use tcltk ; then
sed -i \
-e "s:/usr/bin/X11:${GAMES_BINDIR}:" \
-e "s:/usr/local/bin:${GAMES_BINDIR}:" \
- -e "s:/usr/local/lib/koules:${GAMES_DATADIR}/${PN}:" \
- koules.tcl
+ -e "s:/usr/local/lib/koules:${GAMES_DATADIR}/${PN}:" koules.tcl \
+ || die "sed koules.tcl failed"
else
- sed -i 's:exec.*tcl:exec xkoules "$@":' koules
+ sed -i \
+ -e 's:exec.*tcl:exec xkoules "$@":' koules \
+ || die "sed koules failed"
fi
ln -s xkoules.6 xkoules.man
ln -s xkoules.6 xkoules._man
@@ -62,28 +62,31 @@ src_unpack() {
src_compile() {
mkdir bins
- if [ `use X` ] || [ -z "`use X``use svga`" ] ; then
+ if ! use svga ; then
xmkmf -a
- sed -i "/^ *CFLAGS =/s:$: ${CFLAGS}:" Makefile
- make || die "emake X failed"
+ sed -i \
+ -e "/^ *CFLAGS =/s:$: ${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+ emake -j1 || die "emake X failed"
mv xkoules bins/
fi
- if [ `use svga` ] ; then
+ if use svga ; then
make clean
ln -s ../init.o svgalib/
- make -f Makefile.svgalib || die "emake svga failed"
+ emake -j1 -f Makefile.svgalib || die "emake svga failed"
mv koules.svga bins/
fi
}
src_install() {
- dogamesbin bins/*
- exeinto ${GAMES_DATADIR}/${PN}
- doexe koules.sndsrv.linux
- [ `use tcltk` ] && dogamesbin koules.tcl
+ dogamesbin koules bins/* || die "dogamesbin failed"
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe koules.sndsrv.linux || die "doexe failed"
+ if use tcltk ; then
+ dogamesbin koules.tcl || die "dogamebin failed (tcl)"
+ fi
insinto ${GAMES_DATADIR}/${PN}
- doins sounds/*
- dogamesbin koules
+ doins sounds/* || die "doins failed (sounds)"
doman xkoules.6
use svga && doman koules.svga.6