summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-10 19:30:06 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-10 19:30:06 +0000
commit63a3c11fe078fc1618c1449a68c5ce11a0099f0a (patch)
treeb3f59ee1a6300301a2292dd444d3eb2905b78fc2 /games-arcade
parentVersion Bump from upstream. (diff)
downloadgentoo-2-63a3c11fe078fc1618c1449a68c5ce11a0099f0a.tar.gz
gentoo-2-63a3c11fe078fc1618c1449a68c5ce11a0099f0a.tar.bz2
gentoo-2-63a3c11fe078fc1618c1449a68c5ce11a0099f0a.zip
Added a new revision to work with the split openal/freealut.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/excido/ChangeLog10
-rw-r--r--games-arcade/excido/excido-0.1.5c-r1.ebuild48
-rw-r--r--games-arcade/excido/files/digest-excido-0.1.5c2
-rw-r--r--games-arcade/excido/files/digest-excido-0.1.5c-r13
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-alut.patch11
5 files changed, 72 insertions, 2 deletions
diff --git a/games-arcade/excido/ChangeLog b/games-arcade/excido/ChangeLog
index b1b023ddfe7b..a1f94399be89 100644
--- a/games-arcade/excido/ChangeLog
+++ b/games-arcade/excido/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/excido
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/excido/ChangeLog,v 1.9 2005/06/15 18:10:07 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/excido/ChangeLog,v 1.10 2006/05/10 19:30:06 wolf31o2 Exp $
+
+*excido-0.1.5c-r1 (10 May 2006)
+
+ 10 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/excido-0.1.5c-alut.patch, +excido-0.1.5c-r1.ebuild:
+ Added a new revision to work with the split openal/freealut.
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> -excido-0.1.2.ebuild,
excido-0.1.3.ebuild, excido-0.1.5c.ebuild:
diff --git a/games-arcade/excido/excido-0.1.5c-r1.ebuild b/games-arcade/excido/excido-0.1.5c-r1.ebuild
new file mode 100644
index 000000000000..bc55c222d719
--- /dev/null
+++ b/games-arcade/excido/excido-0.1.5c-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/excido/excido-0.1.5c-r1.ebuild,v 1.1 2006/05/10 19:30:06 wolf31o2 Exp $
+
+inherit games toolchain-funcs
+
+DESCRIPTION="A fast paced action game"
+HOMEPAGE="http://icculus.org/excido/"
+SRC_URI="http://icculus.org/excido/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-games/physfs
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ ~media-libs/openal-0.0.8
+ media-libs/freealut"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-alut.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCXX)" \
+ PREFIX="/usr" \
+ BINDIR="${GAMES_BINDIR}/" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ || die "emake failed"
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}"
+ make \
+ PREFIX="${D}/usr" \
+ BINDIR="${D}${GAMES_BINDIR}/" \
+ DATADIR="${D}${GAMES_DATADIR}/${PN}/" \
+ install || die "make install failed"
+ dodoc BUGS CHANGELOG HACKING README TODO \
+ keyguide.txt data/CREDITS data/*.txt
+ prepgamesdirs
+}
diff --git a/games-arcade/excido/files/digest-excido-0.1.5c b/games-arcade/excido/files/digest-excido-0.1.5c
index 9e28029952e4..530ec4ddc830 100644
--- a/games-arcade/excido/files/digest-excido-0.1.5c
+++ b/games-arcade/excido/files/digest-excido-0.1.5c
@@ -1 +1,3 @@
MD5 2145a3921f57abdc8a965c0086cbddec excido-0.1.5c-src.tar.bz2 2981629
+RMD160 22594630726e2e5f95268dd25897d31ff69a4287 excido-0.1.5c-src.tar.bz2 2981629
+SHA256 d53bcaf4e18265ece7c4206c91cdf26682ff1aeba917cb9d5bd2f4218ce364ef excido-0.1.5c-src.tar.bz2 2981629
diff --git a/games-arcade/excido/files/digest-excido-0.1.5c-r1 b/games-arcade/excido/files/digest-excido-0.1.5c-r1
new file mode 100644
index 000000000000..530ec4ddc830
--- /dev/null
+++ b/games-arcade/excido/files/digest-excido-0.1.5c-r1
@@ -0,0 +1,3 @@
+MD5 2145a3921f57abdc8a965c0086cbddec excido-0.1.5c-src.tar.bz2 2981629
+RMD160 22594630726e2e5f95268dd25897d31ff69a4287 excido-0.1.5c-src.tar.bz2 2981629
+SHA256 d53bcaf4e18265ece7c4206c91cdf26682ff1aeba917cb9d5bd2f4218ce364ef excido-0.1.5c-src.tar.bz2 2981629
diff --git a/games-arcade/excido/files/excido-0.1.5c-alut.patch b/games-arcade/excido/files/excido-0.1.5c-alut.patch
new file mode 100644
index 000000000000..b1ca15d0cee2
--- /dev/null
+++ b/games-arcade/excido/files/excido-0.1.5c-alut.patch
@@ -0,0 +1,11 @@
+--- excido-0.1.5c/Makefile.orig 2006-05-10 15:08:53.000000000 -0400
++++ excido-0.1.5c/Makefile 2006-05-10 15:09:05.000000000 -0400
+@@ -2,7 +2,7 @@
+ CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
+ #CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
+ OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
+-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
++LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU -lalut
+ #LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
+ PREFIX=/usr/local
+ BINDIR=$(PREFIX)/bin/