summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-18 19:34:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-18 19:34:49 +0000
commit3af56bc94379e8ce9b1e03bf82a89bd0a255a4f3 (patch)
tree9ae6ac50f21fbc8dbc4a75964c1a49846833e8c4 /games-arcade
parentversion bump (diff)
downloadgentoo-2-3af56bc94379e8ce9b1e03bf82a89bd0a255a4f3.tar.gz
gentoo-2-3af56bc94379e8ce9b1e03bf82a89bd0a255a4f3.tar.bz2
gentoo-2-3af56bc94379e8ce9b1e03bf82a89bd0a255a4f3.zip
add patch for building with gcc4.3 submitted by Peter Alfredsen via bug #218299
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/criticalmass/ChangeLog9
-rw-r--r--games-arcade/criticalmass/criticalmass-1.0.0.ebuild12
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.0-gcc43.patch101
3 files changed, 117 insertions, 5 deletions
diff --git a/games-arcade/criticalmass/ChangeLog b/games-arcade/criticalmass/ChangeLog
index 3db544115370..92766609cf15 100644
--- a/games-arcade/criticalmass/ChangeLog
+++ b/games-arcade/criticalmass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/criticalmass
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.12 2006/01/02 03:19:31 mr_bones_ Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.13 2008/04/18 19:34:48 mr_bones_ Exp $
+
+ 18 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/criticalmass-1.0.0-gcc43.patch, criticalmass-1.0.0.ebuild:
+ add patch for building with gcc4.3 submitted by Peter Alfredsen via bug
+ #218299
*criticalmass-1.0.0 (02 Jan 2006)
diff --git a/games-arcade/criticalmass/criticalmass-1.0.0.ebuild b/games-arcade/criticalmass/criticalmass-1.0.0.ebuild
index 228cc05ebbbe..77bdbcbdac49 100644
--- a/games-arcade/criticalmass/criticalmass-1.0.0.ebuild
+++ b/games-arcade/criticalmass/criticalmass-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/criticalmass-1.0.0.ebuild,v 1.1 2006/01/02 03:19:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/criticalmass-1.0.0.ebuild,v 1.2 2008/04/18 19:34:48 mr_bones_ Exp $
inherit eutils games
@@ -19,8 +19,14 @@ DEPEND="media-libs/sdl-mixer
S=${WORKDIR}/CriticalMass-${PV}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dohtml Readme.html
dodoc TODO
newicon critter.png ${PN}.png
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.0-gcc43.patch b/games-arcade/criticalmass/files/criticalmass-1.0.0-gcc43.patch
new file mode 100644
index 000000000000..e57c11f5af28
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.0-gcc43.patch
@@ -0,0 +1,101 @@
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -21,10 +21,12 @@
+ distribution.
+ */
+
+ #include "tinyxml.h"
+
++#include <cstring>
++
+
+ TiXmlNode::TiXmlNode( NodeType _type )
+ {
+ parent = 0;
+ type = _type;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.h 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.h 2008-04-18 19:40:35.000000000 +0200
+@@ -28,10 +28,11 @@
+ #ifdef _MSC_VER
+ #pragma warning( disable : 4530 )
+ #pragma warning( disable : 4786 )
+ #endif
+
++#include <cstdlib>
+ #include <string>
+ #include <stdio.h>
+ #include <assert.h>
+
+ class TiXmlDocument;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxmlparser.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxmlparser.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -23,10 +23,12 @@
+
+
+ #include "tinyxml.h"
+ #include <ctype.h>
+
++#include <cstring>
++
+ const char* TiXmlBase::SkipWhiteSpace( const char* p )
+ {
+ while ( p && *p &&
+ ( isspace( *p ) || *p == '\n' || *p == '\r' ) )
+ p++;
+--- CriticalMass-1.0.0.orig/utils/ResourceManager.cpp 2005-01-02 03:59:29.000000000 +0100
++++ CriticalMass-1.0.0/utils/ResourceManager.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -20,10 +20,12 @@
+ #include <ResourceManager.hpp>
+ #include <FindHash.hpp>
+ #include <Endian.hpp>
+ #include <WalkDirectory.hpp>
+
++#include <cstring>
++
+ #ifdef WIN32
+ const char PATH_SEPERATOR = '\\';
+ #else
+ const char PATH_SEPERATOR = '/';
+ #endif
+--- CriticalMass-1.0.0.orig/utils/Value.hpp 2004-12-18 03:41:24.000000000 +0100
++++ CriticalMass-1.0.0/utils/Value.hpp 2008-04-18 19:40:35.000000000 +0200
+@@ -13,10 +13,11 @@
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
+ #ifndef _Value_hpp_
+ #define _Value_hpp_
+
++#include <cstdlib>
+ #include <stdio.h>
+ #include <string>
+
+ #include <Trace.hpp>
+
+--- CriticalMass-1.0.0.orig/utils/zStreamBufferImplZLib.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStreamBufferImplZLib.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <zStreamBufferImplZLib.hpp>
+
+ bool ziStreamBufferImplZLib::init( void)
+ {
+--- CriticalMass-1.0.0.orig/utils/zStream.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStream.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <Endian.hpp>
+ #include <zStream.hpp>
+ #include <zStreamBufferImplLZMA.hpp>
+ #include <zStreamBufferImplZLib.hpp>