summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-06 18:21:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-06 18:21:27 +0000
commit1facecedf53c33eb05b5954fd4157ff5638506a0 (patch)
tree6d79bbb93dae125ee8a42a3969cee8aebeb97ec9 /games-arcade
parentStable on amd64 wrt bug #365577 (diff)
downloadgentoo-2-1facecedf53c33eb05b5954fd4157ff5638506a0.tar.gz
gentoo-2-1facecedf53c33eb05b5954fd4157ff5638506a0.tar.bz2
gentoo-2-1facecedf53c33eb05b5954fd4157ff5638506a0.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/criticalmass/ChangeLog18
-rw-r--r--games-arcade/criticalmass/criticalmass-1.0.2.ebuild41
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch101
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch11
-rw-r--r--games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch33
5 files changed, 202 insertions, 2 deletions
diff --git a/games-arcade/criticalmass/ChangeLog b/games-arcade/criticalmass/ChangeLog
index 8e0ad7e2bf3d..df379bc681a7 100644
--- a/games-arcade/criticalmass/ChangeLog
+++ b/games-arcade/criticalmass/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for games-arcade/criticalmass
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.19 2010/10/15 12:36:01 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/ChangeLog,v 1.20 2011/05/06 18:21:27 mr_bones_ Exp $
+
+ 06 May 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +criticalmass-1.0.2.ebuild, +files/criticalmass-1.0.2-gcc43.patch,
+ +files/criticalmass-1.0.2-libpng14.patch,
+ +files/criticalmass-1.0.2-system_curl.patch:
+ version bump
+
+*criticalmass-1.0.2 (06 May 2011)
+
+ 06 May 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +criticalmass-1.0.2.ebuild, +files/criticalmass-1.0.2-gcc43.patch,
+ +files/criticalmass-1.0.2-libpng14.patch,
+ +files/criticalmass-1.0.2-system_curl.patch:
+ version bump
15 Oct 2010; Brent Baude <ranger@gentoo.org> criticalmass-1.0.0-r1.ebuild:
stable ppc, bug 313911
diff --git a/games-arcade/criticalmass/criticalmass-1.0.2.ebuild b/games-arcade/criticalmass/criticalmass-1.0.2.ebuild
new file mode 100644
index 000000000000..63c454c13860
--- /dev/null
+++ b/games-arcade/criticalmass/criticalmass-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/criticalmass/criticalmass-1.0.2.ebuild,v 1.1 2011/05/06 18:21:27 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="SDL/OpenGL space shoot'em up game"
+HOMEPAGE="http://criticalmass.sourceforge.net/"
+SRC_URI="mirror://sourceforge/criticalmass/CriticalMass-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-mixer
+ media-libs/sdl-image[png]
+ media-libs/libpng
+ virtual/opengl
+ net-misc/curl"
+
+S=${WORKDIR}/CriticalMass-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-system_curl.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+ rm -rf curl
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm -f "${D}${GAMES_BINDIR}/Packer"
+ dohtml Readme.html
+ dodoc TODO
+ newicon critter.png ${PN}.png
+ make_desktop_entry critter "Critical Mass"
+ prepgamesdirs
+}
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
new file mode 100644
index 000000000000..e57c11f5af28
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-gcc43.patch
@@ -0,0 +1,101 @@
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -21,10 +21,12 @@
+ distribution.
+ */
+
+ #include "tinyxml.h"
+
++#include <cstring>
++
+
+ TiXmlNode::TiXmlNode( NodeType _type )
+ {
+ parent = 0;
+ type = _type;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxml.h 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxml.h 2008-04-18 19:40:35.000000000 +0200
+@@ -28,10 +28,11 @@
+ #ifdef _MSC_VER
+ #pragma warning( disable : 4530 )
+ #pragma warning( disable : 4786 )
+ #endif
+
++#include <cstdlib>
+ #include <string>
+ #include <stdio.h>
+ #include <assert.h>
+
+ class TiXmlDocument;
+--- CriticalMass-1.0.0.orig/tinyxml/tinyxmlparser.cpp 2003-03-03 03:34:58.000000000 +0100
++++ CriticalMass-1.0.0/tinyxml/tinyxmlparser.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -23,10 +23,12 @@
+
+
+ #include "tinyxml.h"
+ #include <ctype.h>
+
++#include <cstring>
++
+ const char* TiXmlBase::SkipWhiteSpace( const char* p )
+ {
+ while ( p && *p &&
+ ( isspace( *p ) || *p == '\n' || *p == '\r' ) )
+ p++;
+--- CriticalMass-1.0.0.orig/utils/ResourceManager.cpp 2005-01-02 03:59:29.000000000 +0100
++++ CriticalMass-1.0.0/utils/ResourceManager.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -20,10 +20,12 @@
+ #include <ResourceManager.hpp>
+ #include <FindHash.hpp>
+ #include <Endian.hpp>
+ #include <WalkDirectory.hpp>
+
++#include <cstring>
++
+ #ifdef WIN32
+ const char PATH_SEPERATOR = '\\';
+ #else
+ const char PATH_SEPERATOR = '/';
+ #endif
+--- CriticalMass-1.0.0.orig/utils/Value.hpp 2004-12-18 03:41:24.000000000 +0100
++++ CriticalMass-1.0.0/utils/Value.hpp 2008-04-18 19:40:35.000000000 +0200
+@@ -13,10 +13,11 @@
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
+ #ifndef _Value_hpp_
+ #define _Value_hpp_
+
++#include <cstdlib>
+ #include <stdio.h>
+ #include <string>
+
+ #include <Trace.hpp>
+
+--- CriticalMass-1.0.0.orig/utils/zStreamBufferImplZLib.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStreamBufferImplZLib.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <zStreamBufferImplZLib.hpp>
+
+ bool ziStreamBufferImplZLib::init( void)
+ {
+--- CriticalMass-1.0.0.orig/utils/zStream.cpp 2005-07-31 22:06:14.000000000 +0200
++++ CriticalMass-1.0.0/utils/zStream.cpp 2008-04-18 19:40:35.000000000 +0200
+@@ -10,10 +10,11 @@
+ //
+ // This program is distributed in the hope that it will be useful, but WITHOUT
+ // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
+ //
++#include <cstdlib>
+ #include <Trace.hpp>
+ #include <Endian.hpp>
+ #include <zStream.hpp>
+ #include <zStreamBufferImplLZMA.hpp>
+ #include <zStreamBufferImplZLib.hpp>
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
new file mode 100644
index 000000000000..882869b43a14
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-libpng14.patch
@@ -0,0 +1,11 @@
+--- configure.in
++++ configure.in
+@@ -99,7 +99,7 @@ if test "x$TARGET" = xWIN32; then
+ else
+ LIBS="-L/usr/local/lib -L/usr/X11R6/lib $LIBS"
+ CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
+- AC_CHECK_LIB(png12, main,, AC_MSG_ERROR(libpng is needed))
++ AC_CHECK_LIB(png, main,, AC_MSG_ERROR(libpng is needed))
+ AC_CHECK_LIB(z, main,, AC_MSG_ERROR(libz is needed))
+ if test "x$TARGET" = xUNIX; then
+ if test "x$enable_dyngl" = xoff; then
diff --git a/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch b/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch
new file mode 100644
index 000000000000..02307ad7d8fc
--- /dev/null
+++ b/games-arcade/criticalmass/files/criticalmass-1.0.2-system_curl.patch
@@ -0,0 +1,33 @@
+--- configure.in
++++ configure.in
+@@ -115,8 +115,6 @@ fi
+ AC_CHECK_LIB(m, sin,,
+ AC_MSG_ERROR(libm is needed))
+
+-AC_CONFIG_SUBDIRS(curl)
+-
+ AC_OUTPUT(Makefile utils/Makefile utilssdl/Makefile utilsgl/Makefile game/Makefile tools/Makefile data/Makefile data/music/Makefile tinyxml/Makefile)
+
+ echo "Configuration:
+--- game/Makefile.am
++++ game/Makefile.am
+@@ -41,7 +41,7 @@ critter_SOURCES = \
+ main.cpp
+
+ LDADD = \
+- ../curl/lib/libcurl.a \
++ -lcurl \
+ ../utils/libutils.a \
+ ../utilssdl/libutilssdl.a \
+ ../utilsgl/libutilsgl.a \
+--- Makefile.am
++++ Makefile.am
+@@ -4,7 +4,7 @@
+ AUTOMAKE_OPTIONS = 1.4
+
+ ## Any directories that you want built and installed should go here.
+-SUBDIRS = curl tinyxml utils utilssdl utilsgl tools data game
++SUBDIRS = tinyxml utils utilssdl utilsgl tools data game
+
+ ## Any directories you want a part of the distribution should be listed
+ ## here, as well as have a Makefile generated at the end of configure.in