summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-10-25 19:05:52 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-10-25 19:05:52 +0000
commitd6500468a4e4894c9431d11f53f0f14aff22c811 (patch)
treef6dcdc285fec507fefac689ae7f3882aa5cea83f /games-arcade/opentyrian
parentSupport USE=modules for kernels with merged speakup. Not compile tested as sp... (diff)
downloadgentoo-2-d6500468a4e4894c9431d11f53f0f14aff22c811.tar.gz
gentoo-2-d6500468a4e4894c9431d11f53f0f14aff22c811.tar.bz2
gentoo-2-d6500468a4e4894c9431d11f53f0f14aff22c811.zip
Version bump; upstream switched from subversion to mercurial. The build system has changed and now needs to be fought to a degree where a debug USE-flag is no longer feasible.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/opentyrian')
-rw-r--r--games-arcade/opentyrian/ChangeLog10
-rw-r--r--games-arcade/opentyrian/files/20091025-cflag-idiocy.diff12
-rw-r--r--games-arcade/opentyrian/files/20091025-datapath.diff26
-rw-r--r--games-arcade/opentyrian/opentyrian-20091025.ebuild45
4 files changed, 92 insertions, 1 deletions
diff --git a/games-arcade/opentyrian/ChangeLog b/games-arcade/opentyrian/ChangeLog
index c35cd93863c6..23bd673b5f2e 100644
--- a/games-arcade/opentyrian/ChangeLog
+++ b/games-arcade/opentyrian/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/opentyrian
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.6 2009/07/04 14:01:09 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.7 2009/10/25 19:05:51 chainsaw Exp $
+
+*opentyrian-20091025 (25 Oct 2009)
+
+ 25 Oct 2009; <chainsaw@gentoo.org> +files/20091025-cflag-idiocy.diff,
+ +opentyrian-20091025.ebuild, +files/20091025-datapath.diff:
+ Version bump; upstream switched from subversion to mercurial. The build
+ system has changed and now needs to be fought to a degree where a debug
+ USE-flag is no longer feasible.
*opentyrian-20090702 (04 Jul 2009)
diff --git a/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff b/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff
new file mode 100644
index 000000000000..29ed57c2e29d
--- /dev/null
+++ b/games-arcade/opentyrian/files/20091025-cflag-idiocy.diff
@@ -0,0 +1,12 @@
+--- opentyrian/Makefile.orig 2009-10-25 00:52:54.401229746 +0100
++++ opentyrian/Makefile 2009-10-25 00:54:37.642954736 +0100
+@@ -49,9 +49,6 @@
+
+ # FLAGS ####################################################
+
+-NDEBUG_FLAGS := -g0 -O2 -DNDEBUG
+-DEBUG_FLAGS := -g3 -O0 -Werror
+-
+ CFLAGS += --std=c99 -pedantic -Wall -Wextra -Wno-sign-compare -Wno-missing-field-initializers
+ CFLAGS += -I./src -I$(INCLUDEDIR)
+ LDFLAGS += -L$(LIBDIR) -lm
diff --git a/games-arcade/opentyrian/files/20091025-datapath.diff b/games-arcade/opentyrian/files/20091025-datapath.diff
new file mode 100644
index 000000000000..e83447ebf8f5
--- /dev/null
+++ b/games-arcade/opentyrian/files/20091025-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian.ORIG/Makefile opentyrian/Makefile
+--- opentyrian.ORIG/Makefile 2009-10-25 00:45:41.958937396 +0100
++++ opentyrian/Makefile 2009-10-25 00:47:31.759940038 +0100
+@@ -73,6 +73,10 @@
+ CFLAGS += -DHG_REV='"$(HG_REV)"'
+ endif
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all
+diff -uNr opentyrian.ORIG/src/file.c opentyrian/src/file.c
+--- opentyrian.ORIG/src/file.c 2009-10-25 00:45:41.967228200 +0100
++++ opentyrian/src/file.c 2009-10-25 00:50:21.542979700 +0100
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;
diff --git a/games-arcade/opentyrian/opentyrian-20091025.ebuild b/games-arcade/opentyrian/opentyrian-20091025.ebuild
new file mode 100644
index 000000000000..d9cf9d019a56
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-20091025.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/opentyrian-20091025.ebuild,v 1.1 2009/10/25 19:05:51 chainsaw Exp $
+
+inherit eutils games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/mercurial"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-datapath.diff"
+ epatch "${FILESDIR}/${PV}-cflag-idiocy.diff"
+}
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin tyrian || die "Failed to install game binary"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu opentyrian.desktop || die "Failed to install desktop file"
+ doicon tyrian.xpm || die "Failed to install program icon"
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}