summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-01-04 16:16:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-01-04 16:16:01 +0000
commit7acf8e9eedc9891e6583fcab16728e6e3732e43c (patch)
treed49ed553da0be94c9e2694090c67376a5a483f3f /games-arcade/koules/koules-1.4-r2.ebuild
parentinherit multilib (diff)
downloadgentoo-2-7acf8e9eedc9891e6583fcab16728e6e3732e43c.tar.gz
gentoo-2-7acf8e9eedc9891e6583fcab16728e6e3732e43c.tar.bz2
gentoo-2-7acf8e9eedc9891e6583fcab16728e6e3732e43c.zip
Fix build wih svga USE flag
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-arcade/koules/koules-1.4-r2.ebuild')
-rw-r--r--games-arcade/koules/koules-1.4-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-arcade/koules/koules-1.4-r2.ebuild b/games-arcade/koules/koules-1.4-r2.ebuild
index 1f875f23bb2e..0b2304243469 100644
--- a/games-arcade/koules/koules-1.4-r2.ebuild
+++ b/games-arcade/koules/koules-1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r2.ebuild,v 1.5 2010/01/02 19:19:43 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/koules/koules-1.4-r2.ebuild,v 1.6 2010/01/04 16:16:00 tupone Exp $
EAPI=2
inherit eutils games
@@ -39,7 +39,8 @@ S=${WORKDIR}/${PN}${PV}
src_prepare() {
epatch "${WORKDIR}"/${P}-gcc3.patch \
- "${FILESDIR}"/${P}-sndsrv.patch
+ "${FILESDIR}"/${P}-sndsrv.patch \
+ "${FILESDIR}"/${P}-io_h.patch
sed -i \
-e "/^KOULESDIR/s:=.*:=${GAMES_BINDIR}:" \
-e "/^SOUNDDIR/s:=.*:=${GAMES_DATADIR}/${PN}:" Iconfig \
@@ -77,13 +78,11 @@ src_compile() {
-e '/SYSDEFS =/d' \
-e "/^ *CFLAGS =/s:$: ${CFLAGS}:" Makefile \
|| die "sed Makefile failed"
- emake -j1 || die "emake X failed"
+ emake || die "emake X failed"
mv xkoules bins/
fi
if use svga ; then
- make clean
- ln -s ../init.o svgalib/
- emake -j1 -f Makefile.svgalib || die "emake svga failed"
+ emake -f Makefile.svgalib || die "emake svga failed"
mv koules.svga bins/
fi
}