summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-07-27 18:04:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-07-27 18:04:51 +0000
commitb7cff4b371387a5c1708f3495305d378325296ee (patch)
tree650996efad6e1ed92772dc133a17b0b153b32d7a /games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
parentppc stable #278597 (diff)
downloadgentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.tar.gz
gentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.tar.bz2
gentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.zip
Fix building with gcc-4.4, bug #273505
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild')
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
index fa4de0ba4a00..80bd5770ef59 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.4 2009/02/02 09:43:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.5 2009/07/27 18:04:51 nyhm Exp $
EAPI=2
inherit eutils games
@@ -22,9 +22,10 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${P}-src
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_compile() {
emake -C JLib CPU_OPTS="${CXXFLAGS}" || die "emake failed"