summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 07:22:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 07:22:45 +0000
commit74a698d98a3d51936af3696e9be939e4dd1cec7e (patch)
tree70d453463aa0c9cfa180a2f4a1de7c660b88606b /games-arcade/holotz-castle/files
parentExplicitly disable building dotnet grades. Thanks to Brian Danilko <brian@lik... (diff)
downloadgentoo-2-74a698d98a3d51936af3696e9be939e4dd1cec7e.tar.gz
gentoo-2-74a698d98a3d51936af3696e9be939e4dd1cec7e.tar.bz2
gentoo-2-74a698d98a3d51936af3696e9be939e4dd1cec7e.zip
version bump
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'games-arcade/holotz-castle/files')
-rw-r--r--games-arcade/holotz-castle/files/digest-holotz-castle-1.3.81
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch53
2 files changed, 54 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.8 b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.8
new file mode 100644
index 000000000000..8a73b8b4825f
--- /dev/null
+++ b/games-arcade/holotz-castle/files/digest-holotz-castle-1.3.8
@@ -0,0 +1 @@
+MD5 0d842884c943ef200b37057de7ee9f3a holotz-castle-1.3.8-src.tar.gz 3612345
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
new file mode 100644
index 000000000000..e556d76193e9
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
@@ -0,0 +1,53 @@
+--- JLib/Makefile.orig 2006-03-26 23:38:39.000000000 -0500
++++ JLib/Makefile 2006-03-27 01:16:36.000000000 -0500
+@@ -19,7 +19,7 @@
+ endif
+
+ # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
+-CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
++CXXFLAGS=-I. $(CPU_OPTS) `$(SDL_CONFIG) --cflags`
+
+ # Sample LDFLAGS for applications
+ # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+@@ -28,15 +28,14 @@
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++ -shared -fPIC -o $@.so $? \
+- && ar rvus $@.a $? \
++ ar rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++ $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ .PHONY: install
+ install:
+--- src/Makefile.orig 2006-03-27 01:26:18.000000000 -0500
++++ src/Makefile 2006-03-27 01:27:31.000000000 -0500
+@@ -30,7 +30,7 @@
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+-all: JLib HC HCed
++all: HC HCed
+
+ HC_OBJ_MAIN=HolotzCastle.o
+ HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
+@@ -42,8 +42,8 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
+-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++CFLAGS=-I. -I../JLib $(CPU_OPTS) -c `$(SDL_CONFIG) --cflags`
++LDFLAGS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+
+
+ JLib: