summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commitf0759f77429dfcff11fdeb040d0553dd1e8e0bd8 (patch)
treebc451cfc4f19d245b0c6a7f10e547fdc2006db52 /games-arcade/bub-n-bros
parentaction games ! (diff)
downloadgentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.gz
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.bz2
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.zip
arcade games !
Diffstat (limited to 'games-arcade/bub-n-bros')
-rw-r--r--games-arcade/bub-n-bros/ChangeLog8
-rw-r--r--games-arcade/bub-n-bros/Manifest4
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild63
-rw-r--r--games-arcade/bub-n-bros/files/bubnbros-server3
-rw-r--r--games-arcade/bub-n-bros/files/digest-bub-n-bros-1.11
5 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/bub-n-bros/ChangeLog b/games-arcade/bub-n-bros/ChangeLog
new file mode 100644
index 000000000000..2486fda1b8fe
--- /dev/null
+++ b/games-arcade/bub-n-bros/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/bub-n-bros
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+*bub-n-bros-1.1 (12 Jul 2003)
+
+ 12 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Frank Straetz <Frank@KTHXBYE.de> #22493.
diff --git a/games-arcade/bub-n-bros/Manifest b/games-arcade/bub-n-bros/Manifest
new file mode 100644
index 000000000000..6b6e8df75e3c
--- /dev/null
+++ b/games-arcade/bub-n-bros/Manifest
@@ -0,0 +1,4 @@
+MD5 4d9446fbb98b13275c0bf05c19317907 ChangeLog 385
+MD5 e9d9a09b6655075b1598d9bba4674113 bub-n-bros-1.1.ebuild 1677
+MD5 37372966f62c7ba6a5ea751469f1c031 files/bubnbros-server 45
+MD5 73a5fcc499ac4695104f1c74668cae54 files/digest-bub-n-bros-1.1 68
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
new file mode 100644
index 000000000000..640e3ea31060
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/python-2.2*"
+RDEPEND=">=dev-python/pygame-1.5.5"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd ${S}/bubbob
+ python setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd ${S}/display
+ python setup.py build_ext -i || die
+}
+
+src_install() {
+ local dir=${GAMES_LIBDIR}/${PN}
+
+ exeinto ${dir}
+ doexe *.py
+
+ insinto ${dir}
+ cp -r bubbob common display java ${D}/${dir}/
+
+ dodir ${GAMES_BINDIR}
+ dosym ${dir}/pclient-pygame.py ${GAMES_BINDIR}/bubnbros
+ dosym ${dir}/pclient-xshm.py ${GAMES_BINDIR}/bubnbros-x
+ dosym ${dir}/pclient-slow-X.py ${GAMES_BINDIR}/bubnbros-slowx
+
+ dogamesbin ${FILESDIR}/bubnbros-server
+ dosed "s:GENTOO_DIR:${dir}/bubbob/:" ${GAMES_BINDIR}/bubnbros-server
+
+ dodoc INSTALL.txt
+ dohtml *.html
+
+ find ${D}/${dir} -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ einfo "First you must start a server by running \`bubnbros-server\`."
+ einfo "Afterwards you can start the client by running \`bubnbros\`"
+ einfo "or \`bubnbros-x\`. Note that the X version of the game"
+ einfo "doesn't support sound and music."
+
+ games_pkg_postinst
+}
diff --git a/games-arcade/bub-n-bros/files/bubnbros-server b/games-arcade/bub-n-bros/files/bubnbros-server
new file mode 100644
index 000000000000..e60361f89f37
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bubnbros-server
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec python bb.py $@
diff --git a/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.1 b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.1
new file mode 100644
index 000000000000..9db1dff87d21
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.1
@@ -0,0 +1 @@
+MD5 355e6656fb5b18b87a3bcb9e62d73573 bub-n-bros-1.1.tar.gz 10499686