summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-23 15:41:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-23 15:41:12 +0000
commitef0a04d97e7efcf90748aafea99de56dfbe9703c (patch)
treefc81c78372857fa59d2ce856787e7fb1d11f19eb /games-action
parentVersion bump to fix build with gmake 3.82 (bug #336416, thanks to Kacper Kowa... (diff)
downloadgentoo-2-ef0a04d97e7efcf90748aafea99de56dfbe9703c.tar.gz
gentoo-2-ef0a04d97e7efcf90748aafea99de56dfbe9703c.tar.bz2
gentoo-2-ef0a04d97e7efcf90748aafea99de56dfbe9703c.zip
Respect LDFLAGS. Bug #337854
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/dungeon/ChangeLog8
-rw-r--r--games-action/dungeon/dungeon-3.2.3.ebuild11
-rw-r--r--games-action/dungeon/files/dungeon-3.2.3-makefile.patch6
3 files changed, 13 insertions, 12 deletions
diff --git a/games-action/dungeon/ChangeLog b/games-action/dungeon/ChangeLog
index 9e5b8035af00..50a0749629a7 100644
--- a/games-action/dungeon/ChangeLog
+++ b/games-action/dungeon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/dungeon
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.8 2006/06/22 23:56:50 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.9 2010/09/23 15:41:12 tupone Exp $
+
+ 23 Sep 2010; Tupone Alfredo <tupone@gentoo.org> dungeon-3.2.3.ebuild,
+ files/dungeon-3.2.3-makefile.patch:
+ Respect LDFLAGS. Bug #337854 by flameeyes@gentoo.org
22 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
files/dungeon-3.2.3-makefile.patch:
diff --git a/games-action/dungeon/dungeon-3.2.3.ebuild b/games-action/dungeon/dungeon-3.2.3.ebuild
index 633ef0a07115..cb2e5f4abbc8 100644
--- a/games-action/dungeon/dungeon-3.2.3.ebuild
+++ b/games-action/dungeon/dungeon-3.2.3.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.8 2005/03/04 04:20:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.9 2010/09/23 15:41:12 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -18,11 +19,7 @@ DEPEND="dev-lang/f2c"
S=${WORKDIR}/dungn32c
DATS=${GAMES_DATADIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_compile() {
local f
diff --git a/games-action/dungeon/files/dungeon-3.2.3-makefile.patch b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
index 3d98b328c374..58df825a16dd 100644
--- a/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
+++ b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
@@ -16,15 +16,15 @@
game.o machdep.o parser.o subr.o verbs.o gettim.o \
random.o libdungeon.a
- $(CC) -s -o dungeon dungeon.o -L. -ldungeon -lf2c -lm
-+ $(CC) -o dungeon dungeon.o -L. -ldungeon -lf2c -lm
++ $(CC) -o dungeon $(LDFLAGS) dungeon.o -L. -ldungeon -lf2c -lm
textcnv: textcnv.c
- $(CC) -s -o textcnv textcnv.c -lf2c -lm
-+ $(CC) -o textcnv textcnv.c -lf2c -lm
++ $(CC) -o textcnv $(LDFLAGS) textcnv.c -lf2c -lm
bin2txt: bin2txt.c
- $(CC) -s -o bin2txt bin2txt.c -lf2c -lm
-+ $(CC) -o bin2txt bin2txt.c -lf2c -lm
++ $(CC) -o bin2txt $(LDFLAGS) bin2txt.c -lf2c -lm
# The gettim.C and random.C functions enable Dungeon to keep track of the elapsed
# time in the game and to access random number functions. The uppercase suffix