summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-14 23:19:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-14 23:19:42 +0000
commit791f21f1b5b96f2c020bcdaa33477612b8acaf20 (patch)
treeaada0832fac94376263cd726f9a94b03efe26752 /games-action/violetland
parentVersion bump. New template, updated documentation and translations. (diff)
downloadgentoo-2-791f21f1b5b96f2c020bcdaa33477612b8acaf20.tar.gz
gentoo-2-791f21f1b5b96f2c020bcdaa33477612b8acaf20.tar.bz2
gentoo-2-791f21f1b5b96f2c020bcdaa33477612b8acaf20.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-action/violetland')
-rw-r--r--games-action/violetland/ChangeLog8
-rw-r--r--games-action/violetland/violetland-0.2.9.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index 1bfa0fe3ed0b..89b8c794ee76 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.4 2010/02/10 20:35:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.5 2010/03/14 23:19:42 mr_bones_ Exp $
+
+*violetland-0.2.9 (14 Mar 2010)
+
+ 14 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.2.9.ebuild:
+ version bump
*violetland-0.2.8 (10 Feb 2010)
diff --git a/games-action/violetland/violetland-0.2.9.ebuild b/games-action/violetland/violetland-0.2.9.ebuild
new file mode 100644
index 000000000000..31c547dd0635
--- /dev/null
+++ b/games-action/violetland/violetland-0.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.2.9.ebuild,v 1.1 2010/03/14 23:19:42 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="\
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX} \
+ -DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}