summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-26 07:08:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-26 07:08:48 +0000
commitb3a85839d785fb28941d7697c884053bd2b785e0 (patch)
tree752b85096692a9d79bb5100d8a8b4f6eede3690b /games-action/transcend
parentAdd patch to fix build with gcc-4.6 (bug #364781). (diff)
downloadgentoo-2-b3a85839d785fb28941d7697c884053bd2b785e0.tar.gz
gentoo-2-b3a85839d785fb28941d7697c884053bd2b785e0.tar.bz2
gentoo-2-b3a85839d785fb28941d7697c884053bd2b785e0.zip
Fixed build. Bug #362999
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'games-action/transcend')
-rw-r--r--games-action/transcend/ChangeLog7
-rw-r--r--games-action/transcend/transcend-0.3.ebuild17
2 files changed, 16 insertions, 8 deletions
diff --git a/games-action/transcend/ChangeLog b/games-action/transcend/ChangeLog
index d3c0eedfabdb..e500b47f6249 100644
--- a/games-action/transcend/ChangeLog
+++ b/games-action/transcend/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/transcend
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.7 2010/09/16 16:50:09 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.8 2011/04/26 07:08:48 tupone Exp $
+
+ 26 Apr 2011; Tupone Alfredo <tupone@gentoo.org> transcend-0.3.ebuild:
+ Fixed build. Bug #362999 by Diego Elio Pettenò
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> transcend-0.3.ebuild:
virtual/glut -> media-libs/glut
diff --git a/games-action/transcend/transcend-0.3.ebuild b/games-action/transcend/transcend-0.3.ebuild
index 2150ef79ae80..9dfbf4a98829 100644
--- a/games-action/transcend/transcend-0.3.ebuild
+++ b/games-action/transcend/transcend-0.3.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.5 2010/09/16 16:50:09 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.6 2011/04/26 07:08:48 tupone Exp $
+EAPI=2
inherit games
@@ -18,13 +19,13 @@ DEPEND="x11-libs/libXmu
virtual/opengl
virtual/glu
media-libs/freeglut"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
chmod a+x portaudio/configure
+ mkdir portaudio/{lib,bin}
rm -f game/Makefile
cat \
Makefile.GnuLinuxX86 \
@@ -40,9 +41,13 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
+src_configure() {
cd portaudio
egamesconf || die
+}
+
+src_compile() {
+ cd portaudio
emake
cd ../game
emake || die