summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-04-09 16:39:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-04-09 16:39:16 +0000
commit9608912d9124e353d4d054446305500f7d525400 (patch)
treeb76c1a6770bf5729feba6e2471cb4c5a85467e05 /games-action/teeworlds
parentAdd USE=static-libs. (diff)
downloadgentoo-2-9608912d9124e353d4d054446305500f7d525400.tar.gz
gentoo-2-9608912d9124e353d4d054446305500f7d525400.tar.bz2
gentoo-2-9608912d9124e353d4d054446305500f7d525400.zip
switch to Debian patch for wavpack support (bug #351952); always build server
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action/teeworlds')
-rw-r--r--games-action/teeworlds/ChangeLog8
-rw-r--r--games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch16
-rw-r--r--games-action/teeworlds/metadata.xml3
-rw-r--r--games-action/teeworlds/teeworlds-0.5.2.ebuild27
4 files changed, 29 insertions, 25 deletions
diff --git a/games-action/teeworlds/ChangeLog b/games-action/teeworlds/ChangeLog
index ae1fe6d50c5a..1c840dd92693 100644
--- a/games-action/teeworlds/ChangeLog
+++ b/games-action/teeworlds/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/teeworlds
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.2 2010/04/04 13:51:12 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.3 2011/04/09 16:39:16 mr_bones_ Exp $
+
+ 09 Apr 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ teeworlds-0.5.2.ebuild, files/teeworlds-0.5.2-wavpack.patch, metadata.xml:
+ switch to Debian patch for wavpack support (bug #351952); always build server
04 Apr 2010; Markos Chandras <hwoarang@gentoo.org> teeworlds-0.5.2.ebuild:
~amd64 added wrt bug #311593
diff --git a/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch b/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch
index 4cb1e5b7174f..76a2b6a504cd 100644
--- a/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch
+++ b/games-action/teeworlds/files/teeworlds-0.5.2-wavpack.patch
@@ -2,7 +2,7 @@ diff --git a/src/engine/client/ec_snd.c b/src/engine/client/ec_snd.c
index 034dfb2..67e819c 100644
--- a/src/engine/client/ec_snd.c
+++ b/src/engine/client/ec_snd.c
-@@ -359,13 +359,6 @@ static void rate_convert(int sid)
+@@ -359,19 +359,13 @@
}
@@ -16,7 +16,14 @@ index 034dfb2..67e819c 100644
int snd_load_wv(const char *filename)
{
SAMPLE *snd;
-@@ -381,19 +374,12 @@ int snd_load_wv(const char *filename)
+ int sid = -1;
+ char error[100];
+ WavpackContext *context;
++ char completefilename[512];
+
+ /* don't waste memory on sound when we are stress testing */
+ if(config.dbg_stress)
+@@ -381,19 +375,13 @@
if(!sound_enabled)
return 1;
@@ -33,11 +40,12 @@ index 034dfb2..67e819c 100644
snd = &samples[sid];
- context = WavpackOpenFileInput(read_data, error);
-+ context = WavpackOpenFileInput(filename, error, OPEN_2CH_MAX, 0);
++ engine_getpath(completefilename, sizeof(completefilename), filename, IOFLAG_READ);
++ context = WavpackOpenFileInput(completefilename, error, OPEN_2CH_MAX, 0);
if (context)
{
int samples = WavpackGetNumSamples(context);
-@@ -448,9 +434,6 @@ int snd_load_wv(const char *filename)
+@@ -448,9 +436,6 @@
dbg_msg("sound/wv", "failed to open %s: %s", filename, error);
}
diff --git a/games-action/teeworlds/metadata.xml b/games-action/teeworlds/metadata.xml
index 52f6d5ef544d..2a208a3088fe 100644
--- a/games-action/teeworlds/metadata.xml
+++ b/games-action/teeworlds/metadata.xml
@@ -6,8 +6,5 @@
<email>volkmar@gentoo.org</email>
<name>Mounir Lamouri</name>
</maintainer>
- <use>
- <flag name="server">Enable compilation of server</flag>
- </use>
</pkgmetadata>
diff --git a/games-action/teeworlds/teeworlds-0.5.2.ebuild b/games-action/teeworlds/teeworlds-0.5.2.ebuild
index fafb63c3c896..c074b0118928 100644
--- a/games-action/teeworlds/teeworlds-0.5.2.ebuild
+++ b/games-action/teeworlds/teeworlds-0.5.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.5.2.ebuild,v 1.2 2010/04/04 13:51:12 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.5.2.ebuild,v 1.3 2011/04/09 16:39:16 mr_bones_ Exp $
EAPI=2
-
inherit eutils python games
DESCRIPTION="Online multi-player platform 2D shooter"
@@ -13,7 +12,7 @@ SRC_URI="http://www.teeworlds.com/files/${P}-src.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug dedicated server"
+IUSE="debug dedicated"
RDEPEND="
!dedicated? ( media-libs/pnglite
@@ -59,12 +58,10 @@ src_configure() {
src_compile() {
local myopt
- if use dedicated || use server; then
- if use debug; then
- myopt=" server_debug"
- else
- myopt=" server_release"
- fi
+ if use debug; then
+ myopt=" server_debug"
+ else
+ myopt=" server_release"
fi
if ! use dedicated; then
if use debug; then
@@ -78,12 +75,10 @@ src_compile() {
}
src_install() {
- if use dedicated || use server; then
- if use debug; then
- newgamesbin ${PN}_srv_d ${PN}_srv || die "newgamesbin failed"
- else
- dogamesbin ${PN}_srv || die "dogamesbin failed"
- fi
+ if use debug; then
+ newgamesbin ${PN}_srv_d ${PN}_srv || die "newgamesbin failed"
+ else
+ dogamesbin ${PN}_srv || die "dogamesbin failed"
fi
if ! use dedicated; then
if use debug; then