summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 03:39:53 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 03:39:53 +0000
commitdf419f3c3f8848e573521ce4cf7aa1e755c6d2c3 (patch)
tree88378262d56dd9ccde947ed41959b1131e79578c /games-action/rune
parentQA cleanup: unquote ${A}. (diff)
downloadgentoo-2-df419f3c3f8848e573521ce4cf7aa1e755c6d2c3.tar.gz
gentoo-2-df419f3c3f8848e573521ce4cf7aa1e755c6d2c3.tar.bz2
gentoo-2-df419f3c3f8848e573521ce4cf7aa1e755c6d2c3.zip
Fixing quoting.
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/rune')
-rw-r--r--games-action/rune/ChangeLog5
-rw-r--r--games-action/rune/rune-1.07-r2.ebuild46
2 files changed, 27 insertions, 24 deletions
diff --git a/games-action/rune/ChangeLog b/games-action/rune/ChangeLog
index 75fefa5ed851..aa13153edea4 100644
--- a/games-action/rune/ChangeLog
+++ b/games-action/rune/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/rune
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rune/ChangeLog,v 1.15 2008/02/29 18:03:20 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rune/ChangeLog,v 1.16 2008/03/06 03:39:53 wolf31o2 Exp $
+
+ 06 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org> rune-1.07-r2.ebuild:
+ Fixing quoting.
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> rune-1.07-r2.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-action/rune/rune-1.07-r2.ebuild b/games-action/rune/rune-1.07-r2.ebuild
index 856d8be4eac5..abc7a7a42636 100644
--- a/games-action/rune/rune-1.07-r2.ebuild
+++ b/games-action/rune/rune-1.07-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rune/rune-1.07-r2.ebuild,v 1.7 2008/02/29 18:03:20 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rune/rune-1.07-r2.ebuild,v 1.8 2008/03/06 03:39:53 wolf31o2 Exp $
inherit eutils games
@@ -68,7 +68,7 @@ src_install() {
# the most important things: rune and ucc :)
doexe "${CDROM_ROOT}"/bin/x86/rune \
|| die "Could not install rune executable"
- fperms 750 ${dir}/System/{ucc{,-bin},rune-bin} \
+ fperms 750 "${dir}"/System/{ucc{,-bin},rune-bin} \
|| die "Could not make executables executable"
# installing documentation/icon
@@ -83,25 +83,25 @@ src_install() {
done
# copying the texture files
- dodir ${dir}/Textures
+ dodir "${dir}"/Textures
for x in $(find "${CDROM_ROOT}"/Textures/ -type f -printf '%f ')
do
- echo -ne '\271\325\036\214' | cat - ${CDROM_ROOT}/Textures/$x \
- |sed -e '1 s/\(....\)..../\1/' > ${Ddir}/Textures/$x \
+ echo -ne '\271\325\036\214' | cat - "${CDROM_ROOT}"/Textures/$x \
+ |sed -e '1 s/\(....\)..../\1/' > "${Ddir}"/Textures/$x \
|| die "modifying and copying $x"
done
- doins -r ${S}/System || die "Could not copy Linux specific files"
- doins -r ${S}/Help || die "Could not copy Help data"
+ doins -r "${S}"/System || die "Could not copy Linux specific files"
+ doins -r "${S}"/Help || die "Could not copy Help data"
sed -e "s:.*\(\w+/\w+\)\w:\1:"
- for x in $(ls ${S}/patch/{System,Maps,Meshes} |sed -e \
+ for x in $(ls "${S}"/patch/{System,Maps,Meshes} |sed -e \
"s:.*/\([^/]\+/[^/]\+\).patch$:\1:")
do
- xdelta patch ${S}/patch/${x}.patch ${CDROM_ROOT}/${x} ${S}/patch/${x}
- doins ${S}/patch/${x} || die "Could not copy Patch data"
+ xdelta patch "${S}"/patch/${x}.patch "${CDROM_ROOT}"/${x} "${S}"/patch/${x}
+ doins "${S}"/patch/${x} || die "Could not copy Patch data"
done
- insinto ${dir}/System
+ insinto "${dir}"/System
# copying system files from the Windows CD
for x in "${CDROM_ROOT}"/System/*.{int,u,url}; do
@@ -109,21 +109,21 @@ src_install() {
done
# modify the files
- mv ${Ddir}/System/OpenGlDrv.int ${Ddir}/System/OpenGLDrv.int \
+ mv "${Ddir}"/System/OpenGlDrv.int "${Ddir}"/System/OpenGLDrv.int \
|| die "Could not modify System file OpenGlDrv.int"
- mv ${Ddir}/Textures/bloodFX.utx ${Ddir}/Textures/BloodFX.utx \
+ mv "${Ddir}"/Textures/bloodFX.utx "${Ddir}"/Textures/BloodFX.utx \
|| die "Could not modify Texture file bloodFX.utx"
- mv ${Ddir}/Textures/RUNESTONES.UTX ${Ddir}/Textures/RUNESTONES.utx \
+ mv "${Ddir}"/Textures/RUNESTONES.UTX "${Ddir}"/Textures/RUNESTONES.utx \
|| die "Could not modify Texture file RUNESTONES.UTX"
- mv ${Ddir}/Textures/tedd.utx ${Ddir}/Textures/Tedd.utx \
+ mv "${Ddir}"/Textures/tedd.utx "${Ddir}"/Textures/Tedd.utx \
|| die "Could not modify Texture file tedd.utx"
- mv ${Ddir}/Textures/UNDERANCIENT.utx ${Ddir}/Textures/UnderAncient.utx \
+ mv "${Ddir}"/Textures/UNDERANCIENT.utx "${Ddir}"/Textures/UnderAncient.utx \
|| die "Could not modify Texture file UNDERANCIENT.utx"
- rm ${Ddir}/System/{Setup.int,SGLDrv.int,MeTaLDrv.int,Manifest.int,D3DDrv.int,Galaxy.int,SoftDrv.int,WinDrv.int,Window.int} || die "Could not delete not needed System files"
+ rm "${Ddir}"/System/{Setup.int,SGLDrv.int,MeTaLDrv.int,Manifest.int,D3DDrv.int,Galaxy.int,SoftDrv.int,WinDrv.int,Window.int} || die "Could not delete not needed System files"
# the most important things: rune and ucc :)
- doexe ${S}/bin/x86/rune || die "Could not install rune executable"
- fperms 750 ${dir}/System/{ucc,ucc-bin,rune-bin} \
+ doexe "${S}"/bin/x86/rune || die "Could not install rune executable"
+ fperms 750 "${dir}"/System/{ucc,ucc-bin,rune-bin} \
|| die "Could not make executables executable"
# installing documentation/icon
@@ -132,11 +132,11 @@ src_install() {
;;
esac
- use amd64 && mv ${Ddir}/System/libSDL-1.2.so.0 \
- ${Ddir}/System/libSDL-1.2.so.0.backup
+ use amd64 && mv "${Ddir}"/System/libSDL-1.2.so.0 \
+ "${Ddir}"/System/libSDL-1.2.so.0.backup
games_make_wrapper rune ./rune "${dir}" "${dir}"
- make_desktop_entry rune "Rune" rune "Game;ActionGame"
- find ${Ddir} -exec touch '{}' \;
+ make_desktop_entry rune "Rune" rune
+ find "${Ddir}" -exec touch '{}' \;
prepgamesdirs
}