summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-08-31 19:52:05 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-08-31 19:52:05 +0000
commitde224bfa1660c6d542ca9509a140264295583ee1 (patch)
tree8289e58c46296459a8bc758090a8257d8ade82e9 /games-action/maelstrom
parentAdd back sip-3.8* as it's needed by PyQt-3.8.1. (Manifest recommit) (diff)
downloadgentoo-2-de224bfa1660c6d542ca9509a140264295583ee1.tar.gz
gentoo-2-de224bfa1660c6d542ca9509a140264295583ee1.tar.bz2
gentoo-2-de224bfa1660c6d542ca9509a140264295583ee1.zip
Fixed gcc-3.4 compile problems
Diffstat (limited to 'games-action/maelstrom')
-rw-r--r--games-action/maelstrom/ChangeLog6
-rw-r--r--games-action/maelstrom/files/maelstrom-gcc34.patch30
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r1.ebuild5
3 files changed, 39 insertions, 2 deletions
diff --git a/games-action/maelstrom/ChangeLog b/games-action/maelstrom/ChangeLog
index 32c3b8ec46f6..e2267cb6ca05 100644
--- a/games-action/maelstrom/ChangeLog
+++ b/games-action/maelstrom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/maelstrom
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.10 2004/06/24 21:56:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.11 2004/08/31 19:52:05 sekretarz Exp $
+
+ 31 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ maelstrom-3.0.6-r1.ebuild:
+ Fixed gcc-3.4 compile problems
19 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org> maelstrom-3.0.5.ebuild,
maelstrom-3.0.6-r1.ebuild, maelstrom-3.0.6.ebuild:
diff --git a/games-action/maelstrom/files/maelstrom-gcc34.patch b/games-action/maelstrom/files/maelstrom-gcc34.patch
new file mode 100644
index 000000000000..6ceb421f16ba
--- /dev/null
+++ b/games-action/maelstrom/files/maelstrom-gcc34.patch
@@ -0,0 +1,30 @@
+diff -ur Maelstrom-3.0.6-orig/buttonlist.h Maelstrom-3.0.6/buttonlist.h
+--- Maelstrom-3.0.6-orig/buttonlist.h 2004-08-28 01:43:55.867378220 -0400
++++ Maelstrom-3.0.6/buttonlist.h 2004-08-28 01:44:23.700062593 -0400
+@@ -16,7 +16,7 @@
+
+ void Add_Button(Uint16 x, Uint16 y, Uint16 width, Uint16 height,
+ void (*callback)(void)) {
+- struct button *belem;
++ button *belem;
+
+ for ( belem=&button_list; belem->next; belem=belem->next );
+ belem->next = new button;
+@@ -30,7 +30,7 @@
+ }
+
+ void Activate_Button(Uint16 x, Uint16 y) {
+- struct button *belem;
++ button *belem;
+
+ for ( belem=button_list.next; belem; belem=belem->next ) {
+ if ( (x >= belem->x1) && (x <= belem->x2) &&
+@@ -42,7 +42,7 @@
+ }
+
+ void Delete_Buttons(void) {
+- struct button *belem, *btemp;
++ button *belem, *btemp;
+
+ for ( belem=button_list.next; belem; ) {
+ btemp = belem;
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
index 8ce608b59a25..5df50550e243 100644
--- a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
+++ b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.5 2004/06/24 21:56:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.6 2004/08/31 19:52:05 sekretarz Exp $
inherit eutils games
@@ -26,6 +26,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-security.patch
+ # gcc-34 fix
+ epatch ${FILESDIR}/${PN}-gcc34.patch
+
# Install the data into $(datadir)/..., not $(prefix)/games/...
sed -i \
-e "s:(prefix)/games/:(datadir)/:" configure || \