summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 13:08:49 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 13:08:49 +0000
commit450fd2ea75448801a0cf58f7637e7d214fc3fc66 (patch)
treea7893d4f7cd1c97e1d1d192dc7ac726647d10927 /games-action/lugaru
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-450fd2ea75448801a0cf58f7637e7d214fc3fc66.tar.gz
gentoo-2-450fd2ea75448801a0cf58f7637e7d214fc3fc66.tar.bz2
gentoo-2-450fd2ea75448801a0cf58f7637e7d214fc3fc66.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/lugaru')
-rw-r--r--games-action/lugaru/ChangeLog8
-rw-r--r--games-action/lugaru/lugaru-1.0c-r1.ebuild61
2 files changed, 67 insertions, 2 deletions
diff --git a/games-action/lugaru/ChangeLog b/games-action/lugaru/ChangeLog
index 0dbf56d72fb6..fce9698b65f2 100644
--- a/games-action/lugaru/ChangeLog
+++ b/games-action/lugaru/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/lugaru
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru/ChangeLog,v 1.3 2014/04/26 18:04:46 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru/ChangeLog,v 1.4 2014/06/25 13:08:49 mgorny Exp $
+
+*lugaru-1.0c-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> +lugaru-1.0c-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
26 Apr 2014; Ulrich Müller <ulm@gentoo.org> lugaru-1.0c.ebuild:
Fix LICENSE, bug 505608.
@@ -13,4 +18,3 @@
12 May 2010; Mike Frysinger <vapier@gentoo.org> +lugaru-1.0c.ebuild,
+metadata.xml:
Initial ebuild based on current lugaru-demo ebuild.
-
diff --git a/games-action/lugaru/lugaru-1.0c-r1.ebuild b/games-action/lugaru/lugaru-1.0c-r1.ebuild
new file mode 100644
index 000000000000..d2d022a02b76
--- /dev/null
+++ b/games-action/lugaru/lugaru-1.0c-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru/lugaru-1.0c-r1.ebuild,v 1.1 2014/06/25 13:08:49 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker games
+
+DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="${PN}-full-linux-x86-${PV}.bin"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? (
+ || (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ )
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png "
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/lugaru
+
+ insinto "${dir}"
+ doins -r Data
+
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe ${PN}
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+
+ doicon ${PN}.png
+ make_desktop_entry ${PN} Lugaru ${PN}
+
+ prepgamesdirs
+}