summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-09 18:30:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-09 18:30:56 +0000
commite9655ca27fc39680daa64952c8edf156e05ee3a7 (patch)
treeb03158baf3a21797b36c12da7f1ba24a1921bd78 /games-action/extreme-tuxracer
parentVersion bump. (diff)
downloadgentoo-2-e9655ca27fc39680daa64952c8edf156e05ee3a7.tar.gz
gentoo-2-e9655ca27fc39680daa64952c8edf156e05ee3a7.tar.bz2
gentoo-2-e9655ca27fc39680daa64952c8edf156e05ee3a7.zip
Fix building with libpng14 wrt #308651 by Locke Shinseiko (Wizzleby).
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'games-action/extreme-tuxracer')
-rw-r--r--games-action/extreme-tuxracer/ChangeLog9
-rw-r--r--games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild6
-rw-r--r--games-action/extreme-tuxracer/files/extreme-tuxracer-0.5_beta-libpng14.patch40
3 files changed, 51 insertions, 4 deletions
diff --git a/games-action/extreme-tuxracer/ChangeLog b/games-action/extreme-tuxracer/ChangeLog
index 28cd96559c90..ca91227dc9fd 100644
--- a/games-action/extreme-tuxracer/ChangeLog
+++ b/games-action/extreme-tuxracer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/extreme-tuxracer
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/extreme-tuxracer/ChangeLog,v 1.7 2009/08/22 07:33:10 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/extreme-tuxracer/ChangeLog,v 1.8 2010/03/09 18:30:55 ssuominen Exp $
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ extreme-tuxracer-0.5_beta.ebuild,
+ +files/extreme-tuxracer-0.5_beta-libpng14.patch:
+ Fix building with libpng14 wrt #308651 by Locke Shinseiko (Wizzleby).
*extreme-tuxracer-0.5_beta (22 Aug 2009)
diff --git a/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild b/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild
index 47e97b1292b0..8da84def10c4 100644
--- a/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild
+++ b/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild,v 1.1 2009/08/22 07:33:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/extreme-tuxracer/extreme-tuxracer-0.5_beta.ebuild,v 1.2 2010/03/09 18:30:55 ssuominen Exp $
EAPI=2
inherit eutils games
@@ -35,6 +35,8 @@ src_prepare() {
-e '/^localedir/s:=.*:=@localedir@:' \
src/Makefile.in \
|| die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-libpng14.patch
}
src_configure() {
diff --git a/games-action/extreme-tuxracer/files/extreme-tuxracer-0.5_beta-libpng14.patch b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.5_beta-libpng14.patch
new file mode 100644
index 000000000000..020fd9b872d1
--- /dev/null
+++ b/games-action/extreme-tuxracer/files/extreme-tuxracer-0.5_beta-libpng14.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308651
+
+--- src/ppgltk/images/png_reader.cpp
++++ src/ppgltk/images/png_reader.cpp
+@@ -77,7 +77,7 @@ ReaderPNG::ReaderPNG(const char *fileNam
+
+
+ png_get_IHDR(png_ptr, info_ptr, &width, &height,
+- &bit_depth, &color_type, &interlace_type,int_p_NULL, int_p_NULL);
++ &bit_depth, &color_type, &interlace_type,(int *) NULL, (int *) NULL);
+
+ if(bit_depth == 16)
+ png_set_strip_16(png_ptr);
+@@ -88,7 +88,7 @@ ReaderPNG::ReaderPNG(const char *fileNam
+ png_set_expand(png_ptr);
+ png_read_update_info(png_ptr, info_ptr);
+ png_get_IHDR(png_ptr, info_ptr, &width, &height,
+- &bit_depth, &color_type, &interlace_type,int_p_NULL, int_p_NULL);
++ &bit_depth, &color_type, &interlace_type,(int *) NULL, (int *) NULL);
+ }
+
+ if( color_type == PNG_COLOR_TYPE_GRAY ||
+@@ -96,7 +96,7 @@ ReaderPNG::ReaderPNG(const char *fileNam
+ png_set_gray_to_rgb(png_ptr);
+ png_read_update_info(png_ptr, info_ptr);
+ png_get_IHDR(png_ptr, info_ptr, &width, &height,
+- &bit_depth, &color_type, &interlace_type,int_p_NULL, int_p_NULL);
++ &bit_depth, &color_type, &interlace_type,(int *) NULL, (int *) NULL);
+ }
+
+ this->width=width;
+@@ -114,7 +114,7 @@ ReaderPNG::ReaderPNG(const char *fileNam
+ }
+
+ png_read_end(png_ptr, info_ptr);
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ }
+